4K monitor - can't get 3840x2160 setting


#1

Hi there. I wonder if any of you would be able to help.
I have a 27 inch iMac - late 2013. 3.4GHz Intel I5, Nvidia Geforce GTX 775m 2GB running High Sierra v 10.13.3
I recently tried to hook up my Samsung UH750 monitor. The monitor can achieve resolution of 3840 x 2160 however that doesn’t appear as an option in display settings. The best i can see is 1080p or 1600x900
Can someone confirm if I should be able to achieve 3840x2160 and if so how i would go about that.
Many thanks in advance for your input
Shortz


#2

What cable are you using to connect the Samsung monitor to the iMac?

Edit: Also found this, it might help.


#3

Thunderbolt to HDMI. Its a Belkin branded cable.

Thanks i had already read that page, it didn’t seem to help any… I have installed SwitchResX and although it has more resolution options it still doesn’t have the 3840x2160 and most of the extra ones that it includes look like they are for TVs not monitors


#4

You’ll need Thunderbolt to DisplayPort to get full 4K output.


#5

Mini Display Port to 4K hdmi doesn’t work on Macs in my experience. Has the monitor got full size Display Port? If so, do mini display to display port.

For the record, even USB-C to 4K HDMI seems pretty flakey. I think 4K works via HDMI from the last generation MacBook Pros with HDMI.


#6

I’ve got a latest gen MacBook Pro with USB-C. Getting 4K output was a drama on my Dell UHD monitor. I needed to get a Thunderbolt to full DisplayPort cable and not even use any dongles anywhere in the mix. Granted I have a Belkin USB-C port replicator…so that plugs into the MacBook and the display plugs into the replicator…but even when I tried using the Apple official USB-C HDMI dongle straight out of the Mac I couldn’t output full 4K to the monitor via HDMI cable.


#7

In addition to the link @frankie posted, there’s also this: https://support.apple.com/en-nz/HT204154


#8

Thanks all. The monitor has full display port so i will get a thunderbolt to DisplayPort cable and see if that works.
:slight_smile:


#9

Not to nitpick, but what you actually need is Mini Display Port to (standard) Display Port. Depending on length it shouldn’t cost more than $15 - $30.

https://computers.centrecom.com.au/search?w=mini%20display%20port%20to%20display%20port%20cable


#10

I’ve had all sorts of issues on the new MacBook Pros. I think the root of the issues is that the USB-C port is used for 4 things: USB, USB-C Display Port alternate mode, Thunderbolt 3, and also Thunderbolt Display Port alternate mode. I have never seen a Thunderbolt 3 -> Display Port cable (but they are in true Thunderbolt Docks). All the cheap cables and adapters are USB-C Display Port alternate mode (what a mouthful), and Apple’s current implementation of all this is a mess.

For example - Apple’s USB-C Display Port doesn’t work with adapters to Dual Link DVI. So 30-inch Cinema Displays are no more usable. :confused: I haven’t tried with aThunderbolt 3 dock, that’s my last thing to try. I’ve tried every adapter possible for USB-C DPAM, and none of them work.

Sorry about the tangental rant! :wink:


#11

True, but Mini DP on the @op gen Mac is Thunderbolt 2 port. 6 of 1, 1/2 dozen of the other.


#12

True, I realise that, but I would guess OP’ll save money searching for a mDP to DP cable not a “Thunderbolt to DP” cable which will likely be targeted at the Apple market and probably overpriced :joy: (if even such a cable is even advertised - given it doesn’t exist technically…)


#13

oK, so I picked up a mini DP to DP cable from Kogan https://www.kogan.com/au/buy/mini-displayport-displayport-cable-male-male-12m/?utm_campaign=postsaleorderconfirm&utm_source=kogan&utm_medium=email. The image is horribly distorted (with the exception of 1280x720). Is that a problem with the cable or is there something that i am doing wrong? I suspect cable but would welcome your thoughts before I buy another.


#14

Got a photo of what “horribly distorted” looks like?


#15


This is what it looks like


#16

That looks like a dud cable for sure to me. Try Alogic cables.


#17

its a brand new cable and works perfectly at 1280x720 - now 4k alogic cable ordered. If that doesn’t work I’m giving up on the second monitor for the mac and moving it over to the pc…


#18

If you mouse over the “more space” in System Prefs, what does it say as “looks like”?


#19

The screen looks OK when set to larger text. When I hover over more space it suggests that it is going to look OK but when i actually click the setting it goes fuzzy. The attached image is when the resolution is set to 1280x720 and the mouse is hovering over the max resolution setting. -


#20

That would certainly suggest a cable issue to me, it simply cannot handle the ‘bandwidth’ of the signal for the higher resolution.