ATV4 Airplay security


Is this happening to anyone else? Since the most recent ATV update, whenever we connect a new device to Airplay it asks for a code which appears on our TV (annoying if we just want to listen to music and the TV isn’t even on). When I go into security settings on the ATV4, there is no option to turn off Airplay security completely. I have never wanted security on our ATV quite happy just to let anyone connect who is on our network. Has anyone else had this problem? I may completely reset the ATV but that would mean reinstalling everything, which would also be annoying.


Sounds like two factor authentication?


Seems like the latest update has bumped the minimum security level for AirPlay to First-Time Passcode

I’m thinking you could work around this somewhat (suitable for your audio-only scenario) by changing the security level to Password, and making the password something really simple?


This setting is annoying me too. It’s also turning on my TVs at random hours with a “Airplay requires blah blah” warnings. I’ve had to disable AirPlay to stop this. So I have to turn it on before I want to use it. Bloody annoying.


This probably makes the most sense. Password=“airplay”. Couldn’t get easier than that. Still bloody annoying though.