Can't delete images via image capture


#1

Am I missing something or am I not able to delete images from my iPhone via image capture anymore?

This is the first time I’ve tried to import photos from my iPhone 8, last time it was an iPhone 6. Anyway, I can capture the photos but I can’t delete them because the button is greyed out. I can right click and hit delete but it doesn’t actually delete.

Any idea what’s going on here?


#2

I know this may seem obvious, but have you actually got the photos for deletion selected?


#3

Have you unlocked your iPhone before you plug it in to the computer? I don’t use Image Capture, but I’ve noticed that in Photos I can’t delete photos from the phone unless I unlock the phone before connecting to the computer, so I wonder if the same applies here?


#4

Yep, I’ve tried selecting all, some, one with no joy.

Yep, it asks you to unlock the iPhone and Trust the computer before it will even let you download the photos. I’ve also tried plugging it out/in and restarting both along with facing North, sacrificing small animals etc.

This morning I’m back at work on my Windows 10 computer. Similarly, the phone has o be unlocked before you can see anything (although it doesn’t pop up and tell me that), but everything shows up. It doesn’t all disappear when it all the phone auto locks either, just keeps working.

Strangely I can delete photo’s here without any issues. At this point, I’ve only dropped a month’s worth so I can try again tonight and see if it’s magically started working again.


#5

Are the images synced from another source I wonder? I had the same problem a couple of years ago, but I had used iTunes to sync a folder of photos from the Mac over to the iPhone, forgot all about it and later found there were some photos that just couldn’t be deleted from the phone - it took me ages to figure out why :slight_smile:


#6

Nope, we are only talking about screen shots, saved images and photos taken on the iPhone itself.