Cursor disappears in portrait mode


#1

I’ve got my MBP 2017 connected to a 24" monitor and I’m trying to get the OS to display in portrait mode. When I go into display settings and set the rotation to 90 degrees everything displays as it should but the mouse cursor disappears. I’m using a 1st gen Magic Mouse.

It works find on the MBP screen, but when I move it to the now portrait monitor it disappears. I can see it’s technically there because when I manage to move it over something clickable it shows itself for a nanosecond.

I’ve tried doing command+tab, I’ve tried launching mission control, but neither works to bring it back.

The problem is I can’t even select the “keep” button because of this, and it reverts back to landscape in 15 seconds.

Would anybody have any suggestions on what I could do to fix this?


#2

Are you sure it’s not just moving the mouse off screen and positioning the portrait display in a different logical location in the display settings?


#3

Positive


#4

Video showing the behaviour: https://vimeo.com/270561627


#5

Does this problem persist after a reboot?


#6

If you enable Full Keyboard Access to All Controls from Keyboard in System Prefs, you should be able to tab to the keep button in the pop-up window.


#7

Thank you for these suggestions. I followed @bennyling’s advice and that allowed me to apply the rotation, and then I rebooted. Still no cursor unfortunately.

Maybe I should try a thunderbolt 3 to DisplayPort cable…maybe it’s the Setachi dock I’m using causing the issue. I’m presently using HDMI to DVI through it.

One of the downsides of the new MBPs is I just don’t have those cables lying around, I’d have to order them just to test.


#8

Click the “Gather Windows” button on the other screen (where you have cursor) then click confirm. :slight_smile: