Downloading Sierra, is it possible?

#1

There’s a software program that I need to DL. It requires OS 10.12. Searching for Sierra has been fruitless. Apparently it’s out of print. I thought I had it when I clicked a Sierra Download only to get this:

Warning-%20image%20not%20recognized

I don’t want to go to Mojave because from what I’ve read on-line it will render a lot of apps or peripherals unusable………been there done that before.

This is the current status of my MacBook Pro:

About%20this%20mac

Is there a safe way to download Sierra?
I’ve spent several hours trying to find answers so hope someone has some advice, please.

0 Likes

#2

Have you tried following these instructions?

0 Likes

#3

Thanks, Matreya. That’s the site from which I downloaded the disk image that wasn’t recognized. I could try it again I suppose in case the previous attempt was corrupted.

0 Likes

#4

You shouldn’t be downloading a disk image, but rather an installer application with macOS installer resources embedded in the app.

https://itunes.apple.com/us/app/macos-sierra/id1127487414?ls=1&mt=12

0 Likes

#5

That ‘disc image not recognized’ warning is what I got by trying to open this:

53%20PM

I’ll try the link you supplied. Thank you very much.

0 Likes

#6

The message I get when I follow the link is that the site has to be opened with an application. Choose application. I’ve tried several. Which app should I use, please?

0 Likes

#7

The Mac App Store app.

Interesting that the link says that your Mac must be running High Sierra or later? To download Sierra? :thinking:

But give it a go anyway.

0 Likes

#8

Thanks bennyling. That’s how I read it the first time, too. On-re-reading I saw that was to DL a different version.

I just tried the link Matrea supplied in Safari and got a different page from that shown in FireFox. Still no joy. I still need to open an app to proceed and I don’t know which app to choose. Anyone…?

0 Likes

#9

Safari should have automatically redirected the link to the App Store app…

/Applications/App\ Store

Although it might have been called Mac App Store back in the El Capitan days, not sure…

0 Likes

#10

Clicking on ‘download the combo update’ gets this:
Uploading 10.12.6 combo …or something similar. (the hyperlink disappeared when i stopped whatever it was doing.)

Does this mean it was downloading to my computer ? The little circular symbol just went around and around with 0% never altering. Really confused. . I didn’t want to stop it part way through. I hadn’t planned to sit up all night watching it as I understand it takes some time. Was hoping to do it early in the day so I can also get the app I 'm doing this ‘upgrade’ for.

I stopped it because it wouldn’t let me do anything with the computer. Couldn’t upload this reply.

Matreya, the link you just supplied took me to the app store where I had searched for the 10.12.6combo before. 39%20PM|461x196

I was hoping to leave it on the desktop and install it tomorrow but I didn’t get a chance to do anything. It just informed me it was uploading.

0 Likes

#11

Can anyone tell me which application I should choose when directed to do so, Please? See post #6.

0 Likes

#12

WTF?

Is something unclear about both of those posts?

0 Likes

#13

I have followed the link. It tells me it is only available for iOS devices. It offers no opportunity to DL it to my MacBook Pro. I’m apparently missing something here.
Thanks.

0 Likes

#14

Out of curiosity, have you tried downloading whatever software you’re trying to run and using it on El Cap?

0 Likes

#15

Yes. It won’t DL. Tells me I need 10.12 so I tried to DL both 10.12.1 &10.12.6. with no joy.

0 Likes

#16

Clicking on the link to the app store should take you to the app store page for Sierra, it does on my machine. You should not be downloading 10.12.6 combo update, because that only updates machines that already have sierra installed.

0 Likes

#17

Thank you Matreya, I don’t have Sierra yet. I can’t DL Sierra so in desperaration I tried to download the combo .

Is there some new requirement to access the app store? If so I can’t seem to find it. Thanks for your interest.

0 Likes

#18

Try making Safari your default browser instead of firefox. It really shouldn’t be this hard to get to the sierra page on the app store app…

0 Likes

#19

Thank you Matreya. Safari isn’t my default browser but I have tried Safari with no luck.

I’ll try making Safari my default browser tomorrow. Have to quit tonight. I appreciate your input, thank you very much.

How do I access the app store app other than how I have tried,
with no result?

Please see my earlier post about this. I really need to be able to D/L the app I need for work.

0 Likes

#20

This is the ONLY way you can download Sierra, via the app store app, using the method of clicking on the app store link, it initially launching the browser, which in turn launches the app store app and it goes to the HIDDEN Sierra download page.

That this isn’t working suggests 1 of a couple of things:

  1. You’re not doing it properly; or
  2. Your machine’s installation of macOS is out of whack

Your only options if you cannot download sierra is to go to an apple store and get it sorted out, or to buy a copy of Sierra on a USB stick off someone on eBay. e.g. https://www.ebay.com.au/itm/Mac-OS-X-Bootable-USB-installer-drives-From-Mac-OS-X-10-6-to-10-14/112637422088

0 Likes