Help diagnosing issues with my MBP


I have an early 2011 MBP 13” that’s been having a hell of a time these last few months and I’m thinking it might be time to lay it to rest.

Last year we had a bad storm that resulted in the Ethernet port not working so I started using a USB to Ethernet adapter. That worked fine for many months but one day I woke it up to see it had crashed and looking into the error logs it was the adapter causing it.

I thought maybe a bum kext or something so I upgraded to high sierra and that seemed to fix the problem, until about 2 weeks ago when the crashing started happening again and at least once a day sometimes up to 3.

For the last week and a bit now my CPU usage has been through the roof and making it almost impossible to use. It seems to trigger at random times and I can’t find a cause. I though it was software but activity monitor chops and changes which process uses up the CPU and it swaps really quickly.

I decided this afternoon to run a hardware test. It told me I had bad ram. I removed it then redid the test one stick at a time and it detected no fault on either, but each time it told me I had a bad battery.

What’s going on here? Bad USB Ethernet adapter, bad ram, bad battery, dead Ethernet port.

Do you think this is hardware or software? My gut says it’s hardware causing the grief I’m experiencing with the software.

Any ideas? Macs are expensive and I don’t want to buy a new one without exhausting my options first.

Thank you!

New purchases thread!

My first (err, and only) thought:

Bad storm -> Bad ethernet port -> damaged motherboard…?

I presume from your comments that an electrical surge took out the Ethernet port. If that happened, then it’s entirely possible that the damage went beyond the Ethernet port, to the motherboard itself. Perhaps it was only minor damage, but maybe it’s getting worse over time…

As for the cost of buying a new Mac - yep, I wouldn’t touch one at current prices. But there’s plenty of good machines on the 2nd hand market.


This is what I think has happened. I’ve tried just about everything from resetting smc and pram, reinstalling both sierra and high sierra, removing third party software like chrome. I just cannot solve the issue.


Check the health of your battery. Sometimes when the battery starts to fail it can cause all sorts of weird shenanigans…This is sometimes overlooked so I thought I’d mention it.