High Sierra no longer available


#1

I note that High Sierra is no longer available for download (from app store or in purchases list), and to rub salt in to the wound none of the methods to create a High Sierra USB installer (or Sierra) appear to work any more, I have previously downloaded installers as I suspected we’d get to this point. I’ve tested on 3 different Macs running 3 different versions of macOS/OS X - none of Diskmaker X, recommended Apple command line and Install Disk Maker from macdaddy.io work on and of Mojave, High Sierra or El Capitan.

I’m not a big fan of Mojave but now appear to be stuck with it - I could try an Internet recovery to the original version of the OS that came with the machine (Lion) then try to update to High Sierra but given the above issues I think the chances of this working are zero.

I am SERIOUSLY pissed off about this it is utterly pathetic that I can’t install a previous version of the OS


#2

All part of the grand plan. Its why I havent upgraded past Sierra on my laptop and El Cap on the mac mini (although that was unintentional, I had intended to u/g to Sierra… is that doable?)


#3

Try this link MacGeek:

https://itunes.apple.com/us/app/macos-high-sierra/id1246284741?ls=1&mt=12


#4

Thanks I’ll give it a go but not holding my breath that I’ll be able to create install media


#5

Do you lose anything that High Sierra had by using Mojave instead, out of interest?


#6

Thank you so much! That worked perfectly


#7

High Sierra needs to remain available as it’s the last OS for some hardware.


#8

And, some stuff-up by Apple notwithstanding, you should always be able to download it onto said hardware by using one of Internet Recovery’s many options.

Alternatively, you can use the link @Matreya posted, or something like the High Sierra patcher tool to download a copy of the latest installer — the latter of which is the exact method I used earlier this morning to download a fresh copy of macOS High Sierra 10.13.6 from Apple’s servers.

Plenty of ways to skin a cat, as they say, even if macOS releases are no longer named after them.


#9

Apologies for the hijack, kind of related. Am I dreaming or has Mojave removed some of my games? Could have sworn I had a couple more than I do, I’m thinking maybe some games are not compatible with 10.14 and unlike iOS where you get the cloud icon and apps don’t work, maybe Apple have just deleted some games.

Has Apple ever deleted macOS apps? NB: these were from the App Store.


#10

I have never heard of that happening… Do they still show in your Purchased tab?


#11

I have no access to HS (which my Macbook is compatible with) but I can have access to Mojave, which makes no sense because my Macbook is NOT compatible. I do still have both El Cap, and Yosemite in my purchased tab, otoh cant do much about those because I already have Sierra on board. Guess I am stuck. I was going to bite the bullet and update to HS but now cannot (unless, if I try to install Mojave, it offers that as an alternative, havent tried).

Additionally, I had downloaded Sierra on my Mac Mini, but not installed it. It seems to have vaporised. I can’t see how thats possible.

Time to clone both Drives and see whats what.


#12

I know they Can do it, but I’ve never heard of it happen for anything other than iTunes movies that have had licensing changes.

I reckon @kerr may have deleted the apps at some stage and forgotten, and I agree - go look for them in your App Store purchases and see if they’re available there for download.


#13

I’ll check later and report back


#14

Confirmation that Apple have removed the ability to download older versions of OS X in Mojave https://www.macworld.co.uk/news/mac-software/impossible-download-old-macos-3684588/ I didn’t think it was just me

I know that there are other ways to find them but IMHO this is utter arrogance from Apple, once you update then there is no way to go back using official channels.


#15

I’ll be using the other channels then. Arrogance is a kind word about this. Although in some ways I understand, BUT they are completely ignoring the fact that there are some of us who are unable to upgrade hardware for a variety of reasons and no matter how much Apple insists, its just not possible. Or, in my case, justifiable.


#16

I was trying (for a change) to be “nice” about it :slight_smile:


#17

No but you can still get copies of system 7.5.4 and the OS 9.2 updates from the Apple website.


#18

As a hoarder from way back I have copies of 10.5 (Leopard) all the way up to 10.14 (Mojave), I also have many of the combo updates files saved too, although apparently I wasn’t particularly diligent in keeping those. Mostly this means the installer I have is .0 release of each.

Some of the later OSs got a bit narky (or smart depending on how you wanted to look at it) about how old the file you were trying to install was and would fail with no no useful error message while you were attempting to install. The easy fix was to jump into the terminal and manually set the date to the release date for that OS and it all goes fine after that (just have to make sure you set it back to the correct date once it’s installed).

Honestly I should probably delete them and save myself 20GB, online restore is pretty good these days and I’m now on a 100/5 Cable connection (rather than a 3MBit ADSL connection from the old place). But then the NAS is sitting there anyway doing NASy things … and you never know when being able to install Leopard might come in handy :stuck_out_tongue:


#19

I’ve now used Matreya’s link to get it. And diskmakerX.com has a new version out which is compatible with Mojave and presumably for everything before that. I’ve made bootable disks with diskmakerx very successfully in the past… should be all good.


#20

UGH, I was doing the same thing and then recently when looking for my stored installers, remembered that I had let CleanMyMac clean them out, thinking that I could always redownload from the MAS. Didnt occur to me that apple would be so rude as to make those older ones not available anymore.

I’m redownloading those I can get.