How to install Mac OS on old iMac that can't use Mac OS recovery?

I’m trying to get an old iMac working that I (stupidly) erased ready to sell, however I have decided not to and I’m having a hard time getting a working copy of Mac OS installed as it’s too old to use Mac OS recovery.

I’m pretty sure I’ll have to install from a bootable drive, but I’m not sure how to even do that. Any advice?

The iMac is iMac (21.5-inch, Late 2009), I’m not even sure what version of Mac OS it will run!

At 2009 it won’t be getting security updates but you could install Ubuntu Linux on it and get a working and secure system. Just ignore the parts about dual booting because you’ve already erased your Mac OS.


You should be able to install an old version of OSX from CD.


Do you still have the original disks? I have Snow Leopard disks somewhere.

1 Like

That machine should run High Sierra, so should still get security updates for a while, max out the RAM and throw in an SSD and it still has life left in it.

Getting a download of High Sierra is still easy:

Then use this to make the USB installer:

**If you want to run any other flavour of OSX you can basically follow the same steps using Disk Maker X, although you may need an older version depending on how far back you go).

1 Like

You can also use the built in tool to make a bootable installer… :slight_smile:


So I followed these instructions and successfully created the boot disk. I get most of the way through the installation and then up comes an error “An error occurred. Please try again” or something similar. Happens every time and I haven’t been able to get past that :frowning:

@AVC I’m not sure if this is the same issue or not… but I had issues and possibly this same message when trying to install new versions of MacOS on white MacBooks that had lost their date/time - had to resort to changing the time in terminal first before installing to install properly. Any chance your iMac has a dead PRAM battery (assuming modernish iMacs still have one) and is thus reverting to 2000 or something as the date ?

1 Like

I did see this come up as a possible issue online, but I thought I fixed it by running the terminal script to fix the date and time. I’ll give it another go though!

I had this issue with versions of OSX past a certain date. Apparently they timb bomb the installers so if the current date is past that, they want you to download a fresher/more up to date copy before it will work.

I’ve gotten around this by turning the date back to the release date of that version to solve the problem successfully.

TOP TIP: Get yourself a proper highspeed USB stick. I’ve got a couple of32GB SanDisk Extreme USB 3.0 sticks I got a while back that read very fast. Before I got this I had a drawer full of sticks that often couldn’t manage more than about 6MB/s write (often far less) and were also pretty bad at reads with speeds around 8-10MB/s.

They cost me almost $50 each when I got them, but hot damn do they make OS installs so much more pleasant as they tear through the first steps. Even on old machines with USB 2.0 I’ve seen significant decreases in time when you’re going from 10mb/s to 24…
It also make re-writing that new image to a stick much much much quicker when you need to create something new.

They are reserved for OS installs (or short term things I want to happen faster).

Maybe the average stick has gotten better, but I’ve got “USB 3.0” sticks here that probably are USB 3, but just use cheap memory and can’t read/write for shit.

But seriously, if you do installs often, one of these is godsend.

I think I had an issue where I thought I was changing the time but I must have had the command slightly off - I believe there is a terminal prompt to display the system time, perhaps worth running that to confirm that the time really has changed

I got it working :slight_smile: simply had to do a PRAM reset.

Thanks so much for your help everyone!