Importing photos from iPhone - hangs


For a while now I have been trying to import the images that are on my wife’s iPhone 8+, however each and every time during the process the app freezes at some point.

I first tried in Sierra, using Photos, and on multiple occasions it reached around 1000 / 1600 and froze.

I went back to Mavericks and tried in iPhoto, but iPhoto wasn’t even seeing the phone.

Back in Sierra, again Photos, I attempted breaking the 1600 images down… doing around 200 at a time. This looked to be working til - it hung again.

I’ve now just tried using Preview, and you guessed it - hung, this time after only about 200 photos.

What’s going on?

What’s the solution?



Ok - I’ve been doing really small packets of images via Preview… and it’s giving me an error after a particular image.

The operation couldn’t be completed. ( error -9912)

It looks like every image after that one will not download…

If it’s a corrupted image, delete it, import the others, then undelete and try again (or airdrop it maybe).

Thanks for the delete / I delete idea - I’ll try tonight.