Is there a way to ignore the neighbour's wifi AP?


Sure have, been with Vodafone since 2008 when the iPhone was released in Australia.

That said, there’s a possibility other SIM cards have been temporarily installed in the phone at one time or another when I was doing some testing for clients. So in theory that could have pulled some different carrier settings down.


Ever since the NBN was installed in my area I have a Fon Wifi and Telstra Air hotspot its the bane of my life with regard to the internet.


Its not mine. I’ll have a chat with the owner on the weekend and see if she will do it. She may not even be aware that its on by default.


Maybe it is something to do with WiFi calling? The Voda profile may be logging you in to redirect calls via the net. Try switching WiFi Calling off, if it is on, and see if that makes a difference?