Issue scanning to SMB share


I have an issue with scanning to a SMB share on a Mac OS X High Sierra based iMac.
The share is set up on the Mac and shared using both SMB and AFP, there is a specific username and password set up with full read/write access to the share - I can access the share from another Mac on the network but when I try and scan from the OKI E4192 MFP printer to the share it gives a user authentication error.

I have double checked the user credentials on the printer and have also tried setting the SMB level on the Mac for both SMB 2 and SMB 1 but get the same error.

Can anyone suggest any other things that I can check/try?

The printer does support scan to FTP so if all else fails I guess I can install an FTP server using Macports or a similar repository but I’d prefer to stick with SMB if I can get it working.

I’d really appreciate any suggestions to help fix this


Have a look at the smb.conf file on the SMB server Mac, and check if the valid users or hosts allow parameters are set for the share. These could both lead to authentication errors.

Thanks I’ll check that out

The machine has as smb.conf.old file, which I assume will not be active but does have an nsmb.conf file containing