Keyboard issues with Mid 2012 13" Macbook Pro

My Mid 2012 (Non Retina) Macbook Pro has recently developed a strange issue with a row of keys - specifically the ‘A’ to ‘L’ keys (9 keys in total). It’s got to the point where it’s now too frustrating to type without the assistance of the keyboard viewer.

If I press any of these keys there’s often a 2 to 3 second delay before the character shows on screen and I have to keep the key depressed for the time before the character will show! Obviously this greatly slows down typing and having to use the keyboard viewer doesn’t make things much faster! I’ve also noticed occasionally when keeping one of the affected keys depressed for the 2-3 seconds results in 4 or 5 of the character appearing like a key repeat is on. Only occasionally, I’d say maybe 10% of the time, do these keys behave normally, but also on occasion I find I have to keep the keys depressed for as long as 5 seconds before a character appears! Though this is usually only after waking the laptop from sleep.

I don’t think it’s a heat issue as it’s not like I begin to have problems with these keys only after I’ve been using the laptop for hours at a time. So whether the laptop has been left on for a while or whether it’s been in sleep mode for a while ( I rarely turn it off) doesn’t seem have much bearing.

I’ve looked at the keyboard settings and options in ‘System Preferences’, but the settings haven’t been changed. Besides the settings are ‘global’ i.e. the settings ‘Key Repeat’ (Off - Slow - Fast), ‘Delay Until Repeat’ (Long - Short) and ‘Enable Slow Keys’ (Delay: Short - Long) will affect all character generating keys equally. Maybe there’s a way to adjust these settings to a row of keys - perhaps through the ‘Terminal’? Then I could perhaps apply a negative amount of delay to the affected keys to bring the keys response time back to normal?

I’ve read a lot of posts on the internet about Macbook/Pro/Air owners having a particular key or group of keys stop working altogether or only work intermittently, but that’s not the case with my Macbook Pro’s keyboard since the affected keys do still work all the time - that is they still generate their respective character when pressed, it’s just that they have to be depressed (held down) for several seconds before a character appears so there’s a lengthly delay being caused or applied. Whether a fault has developed in the keyboard matrix or with the keyboard scan I don’t know? I’ve read replies suggesting a swelling battery could be responsible by pressing on the keyboard. Could that be a possibility here given the behaviour I’m describing?

It’s unlikely to be a swelling battery, as generally you’ll notice the trackpad more affected than a row in the middle of the keyboard.

I’ve never heard of a software solution to this kind of problem; if you want a permanent fix, I suggest taking it to the Apple Store.

Might be a long shot, but just go into System Prefs -> Accessibility -> Keyboard and make sure ‘Enable Slow Keys’ is unchecked, though it’d be unusual that this would just result in the home row keys being unresponsive but worth a look. Maybe have a sticky beak around in there just in case there’s something else it could be.

The trackpad is functioning normally, not that I use it very often. So that means the battery is positioned more or less under the trackpad - correct?

I’d really like to be able to take it in to the Apple Store, but that’s not possible at this time so a Genius Bar appointment would have to be conducted over the phone, which is not to say that wouldn’t be helpful in narrowing the cause, but probably not as helpful as being able to take it in.

The very first thing I checked was System Preferences -> Keyboard & System Preferences -> Accessibility and all settings are the default settings. They’ve not been changed.

‘Enable Slow Keys’ which adjusts the amount of time between when a key is pressed and when it is activated is the exact option needed, but as I say it can’t be applied on a key by key basis or to only a group or row of keys. Perhaps there’s a Terminal command that could give ‘individual’ control than the global settings provided in Accessibility?

Could it be malware somehow doing this? I don’t mean ‘Spyware’ i.e. a ‘keylogger’ (keystroke recorder), but a programme intended simply to mess with a user’s keyboard with the purpose of just annoying or frustrating the user.

When I used to have an ‘IBM Aptiva 14A’ running ‘Windows 98’ it got infected with malware that jumbled all the keys on the keyboard so for example if you pressed the ‘A’ key you might get a ‘Y’ on the screen and if you pressed the ‘Y’ key you might instead get a ‘V’ on the screen. Most annoying!

So could malware be adding an annoying delay to a group of keys on my Macbook Pro and if so how would I know - particularly if ‘Malwarebytes’ finds nothing, though that might not mean there isn’t anything, just that it can only detect what it’s designed to detect. Maybe there’s something hiding in System -> Library -> LaunchAgents? that isn’t legitimate? though every file starts with ‘com.apple’.

I’ve had a similar issue with my Mid 2012 MacBook Pro (purchased in May 2015), the O key stopped registering, but would start again after holding it down a while. Then the whole diagonal row from 9 down to the up and down buttons cut out. I cleaned the keys and it worked for a bit but then broke again so my Mac is at MacMedic in Sydney for a top case replacement. I tried to do the replacement myself, but previous experience from doing a swap on another MacBook was that the Ebay replacement keyboard for this MacBook is of subpar quality, so I ordered through Macfixit, but the the top case that came was dented plus obviously not OEM Apple (Crooked keys, cheap feeling keyboard, port logos not right), so I gave up and booked it into MacMedic.

Wish I could just buy the part from Apple :frowning:

It’s a known issue with the keyboards of that generation of MacBook Pros - my wife had a similar issue - necessitated a whole replacement of the case (under warranty) at the time.

The keyboard on my parent’s Early 2015 13" Macbook Air is functioning perfectly and it’s the same keyboard as on my Macbook Pro.

If it were a hardware cause like worn connectors under the keys, is it possible to just replace those individual keys or rather the connectors under them instead of having to replace the entire upper case with a whole new keyboard/trackpad assembly? I could see that being expensive! My Macbook Pro is obviously way out of warranty. $300.00 could get me a used Macbook Pro (same model) off eBay.

I’d love to be able to take my Macbook Pro into the Apple Store where I’m sure they’d have the diagnostic tools to properly determine the cause, but I can’t do that at this time so I’m going to call Apple Support and speak to a technician and see if they can help?

Is it COVID concerns preventing you taking it into an Apple Store?

If its lack of appointments you can get an appointment if you turn up to an Apple store early or if you keep an eye out on the support place. There are also Apple authorised providers who have appointments.

The first reason - in a manner of speaking. I did actually have an appointment for Thursday morning. I’d say an Apple authorised service provider is out of the question since they all seem to want $$$ just to spend 20 minutes looking at it! The Apple Store Genius Bar will do that for free!

I spoke to Apple Support on Wednesday and explained the issue with the keyboard. He suggested it could be an issue with the OS and that since I was still on Mavericks to update to see if that fixes things.

Well I’ve updated to Yosemite and the unresponsiveness of the ‘A’ through ‘L’ keys still persists, albeit it’s changed slightly in that if I type, the keys now respond normally, though there still seems to be a little bit of a lag, but if I stop typing or don’t use the keyboard for at least 10 seconds, the affected keys become unresponsive again so I have to depress one of them for at least 5 seconds before they start behaving normally again - until I stop using the keyboard again for 10 seconds.

Apple Support have my case details in case I need to contact them again if the suggested fix didn’t work, which it more or less didn’t. I know Yosemite is one of Apple’s poorer OS efforts so I intend to update again, but obviously I’m quickly going to run out of OS’s to update to in the hope it’ll fix things.

I doubt it’s something that went wrong at the kernel level of Mavericks as updating to Yosemite would’ve fixed it, but could it instead be a problem with the EFI (Firmware)? I understand the EFI, among other things, controls the trackpad so I assume also the keyboard?

The Hardware overview states:

Model Identifier: MacBookPro9,2
Boot ROM Version: MBP91.00D3.B0C
SMC Version (system): 2.2f44

I believe it’s all up to date going by https://www.tardisk.com/pages/how-to-check-your-firmware-version

I’ll call Apple Support again early next week to see if there’s anything else I can check or try?