Mac Pro locking up

#1

I have an early 2008 Mac Pro that over the past months has been locking up (Freezing) on occasions.
Often after doing that upon restarting it starts to just a grey screen but leaving it for a day restarts ok but locks up after five minutes or so.

After experimenting what seems to fix it for a time is a Yosemite install (Refresh). After doing that it seems to work ok sometimes for weeks until acting up again.

Anyone have any ideas on whats causing this? If it was a hardware issue my thoughts are that it shouldn’t go away.

0 Likes

#2

Safe Mode do anything?

Tried a different OS ? (Wondering if your copy is corrupted?)

Yes does seem odd.

0 Likes

#3

May be heat related? Clean the fans. Clean and re-seat the RAM/daughter boards

0 Likes

#4

No issues at all in safe mode. Works every time.

Tried other versions also and it does the same.
Never acts up straight away after a new OS install.

0 Likes

#5

Worth a try cleaning. Haven’t tried that.
But if so why does safe mode not act up and an OS refresh tempoeraly fix the problem

0 Likes

#6

Could be GPU related. What card are you running? (Guessing as it is ok in safe mode)

0 Likes

#7

Jaysee yes it could be that.
It’s just the standard Mac Pro card for that model. ATI Radeon HD 2600.
Yes it works fine in safe mode but also works fine (for many weeks sometimes) after a OS refresh which is strange.

0 Likes

#8

Wow a 2600! Those cards are ancient, and were pretty underpowered when they were new! I’ve think I’ve got a GT120 on the shelf here you can have for free if you want it and are happy to cover the postage… it’s a bit newer and better.

0 Likes

#9

Happy to take you up on that offer. If nothing else it’ll show whether it’s a GPU issue or not.
Ancient yes the original that came with the Mac.

0 Likes