Modding an ATV1 - SATA HDD


#1

Have modded the title of this thread - now going to chronicle the possible disaster of me attempting to modify an Apple TV by installing a SATA drive, using an IDE/ATA to SATA adapter card, requiring alterations to the ATV case… See below!


G’day,

Where does one buy a 1TB ATA these days?

Was thinking I’d just pop my spare 1TB MyPassport drive into my brother’s Apple TV, however then read that the ATV uses ATA, not SATA…

Looking around, I’m seeing prices in the hundreds of dollars…!?

Was not expecting that!

Cheers

cosmic


#2

Ebay.


#3

Hi @Orestes,

Ah yep - that’d be the way to go… Though looking round, I need a 2.5" option, and it needs to be fairly small profile to fit inside the box…

Will do more research.


#4

I’m pretty sure there’s adapters for 2.5" drives also.


#5

Here’s one…

But the issue is whether it fits inside the cramped innards of the ATV… Am trying to find someone who has done it, and actually states what adapter they used, but everyone’s too vague!


#6

It should work. The Apple TV uses a version of OS X 10.4 which supports up to 16TB volumes. The adapter that goes behind the drive should not extend significantly above or beyond the drive.

The concern is whether the Apple TV hardware supports 1TB drives.


#7

Yes - ATVs can take a 1TB drive. You can buy them on eBay already modded for about $480 inc post from USA (!). Frankly my brother could afford that option, but somehow I’d rather do it myself…


#8

I haven’t worked with PATA in years. I know for a fact I’ve run SATA drives on very old Macs. I still have an X-Serve in my closet that needs a new PSU. It should be a fairly straightforward swap. If anything you might need to modify the mounting point, but if your as capable as what I believe you are that shouldn’t be a problem either.

The bigger problem now with the ATV1s is that they’re only 720p. The 4th generation is cheap, and the apps make it a better unit. You don’t have to futz about with your phone to get iView or SBS on Demand onto it and Netflix runs native.

You could put a Crystal HD decoder in it but by the time you do that you may as well buy one of those Chinese Android streaming boxes. You can do what you like but for the full experience I wouldn’t waste the $200 it would take to buy an Apple TV 4. I bought an Apple TV 4 for my tech unfriendly aunt, and mother and they are a very solid investment even if you have to setup the apps for them.

There are basically no limitations on what you can do with an AppleTV 4 now. It will even play pong and keep your beer cool in the fridge.


#9

:slight_smile:

Yes, very true. My issue is that my brother, who is the main user, has Down Syndrome and whilst he actually took to using it a lot easier than we anticipated, on the ATV1 I have the ability to hide away unwanted menu options, limiting what he can “get into”. For instance, when I tried using an external HDD via USB, he wiped the contents with the wrong “push of a button/s”.

At any rate, the content he’s mostly viewing is Doctor Who, Classic era DVD rips - so he doesn’t need HD. :slight_smile:


#10

I happen to work with a person with down syndrome and have a previous background in education so happen to have some experience with dealing with difference. What can I say? They are far more capable people than people assume and the rest of the world has to realise we all come in different shapes and sizes.

I wish you all the best with that. If that’s what he’s comfortable with then its probably the best option to go with.


#11

I suggested the idea to my mother a number of times over several years, whilst she contented with him destroying DVDs by using them as coasters, scratching posts, frisbees, etc… (VHS was a much better era, however he was starting to kill VCRs by poking his pencil inside (literally - he carries a pen/pencil everywhere he goes), and forcing the tape up to see the name on the label, instead of just ejecting it.)

Eventually one weekend when I went down to Horsham I took the ATV with me, having set it up with about 50 episodes of WHO, complete with cover art for all of the stories so he could see which was which. Before I’d even mentioned it to him, he found it (in original box of course) and brought it out of my bedroom, very curious and almost like he knew exactly what it was for.

By the time I left on the Sunday afternoon, he was able to navigate through the list of stories (ie up / down) and choose which story he wanted, press play to watch it, or menu to go back. (The only issue, which is still an issue, is that he sometimes goes back too far into the main menu, then can end up somewhere other than NitoTV…)

Suffice to say there’s been issues along the way, but having taught mum how to do a forced restart, most issues have not been huge hurdles.

Hopefully I can get it going again, and with a bigger HDD, I can look at adding some other shows that we grew up watching as well, which I’d achieved with the external hard drive that I tried out a year ago… (until he wiped its content…) :slight_smile:


#12

In XBMC there is a kiosk mode which may help you achieve what you want.


#13

Thanks. :slight_smile: I’ll have a look. I have a version of XBMC on there…


#14

Swapping the stock ATV 160GB (or 40GB) ATA HDD for a larger SATA HDD

G’day,

Following these instructions from iFixit, I have just opened up my brother’s Apple TV - Generation 1. First of all - dusty! Guess it is pretty old, and never been cleaned before. Can-o-Air fixed that.

Looking inside, straight away I can see why people have had to modify the case with a dremel-type tool when adding an ATA -> SATA adapter card - there’s no room! There is a post for a screw in the corner where the HDD is mounted, which will absolutely block any IDE/ATA to SATA adapter from being installed.

One option may be to move the mounting holes for the HDD so the drive is not so close to the post, however there is still another issue - a “fan rail” which runs the length of the right side of the ATV. This however can be removed - or possibly cut in half in order to make room for the adapter. I’ve only seen a few comments as to whether this rail is “required” - the ATV always runs pretty hot - hopefully this wont be an issue.

I have purchased 2 different adapters (at only $6-8 each, I decided to grab both and then figure out which one works best) - one locally but one from China, so have a 3-7 week wait time there.

And:

Will have to see when they arrive which one works best within the space, and what mods they will require.

I’ve also ordered a new 1TB ATA 5500rpm Toshiba HDD for $55.

Next is deciding on what dremel/like tool to buy seems I’ve never owned one. :slight_smile:


#15

I have both the Ozito rotary tool and a Dremel one. The Ozito one is plug in, the Dremel is cordless.

The Dremel is a better tool, especially being it’s cordless, but for one off little jobs the Ozito is just fine. I do recommend buying the dremel bits though as they seem to be better than the ones included in the Ozito box. You can’t really beat $40 in bunnings!


#16

For my own records as much as anything else - will document my progress…

The Aussie-sourced ATA->SATA adapter and the Toshiba 1TB SATA HDD have both now arrived. Whilst the China-sourced ATA->SATA adapter will likely be a better fit inside the ATV due to its smaller form factor, I can at least use the Aussie one to get started. Time to do some work!

Firstly - I actually plugged the ATV in to see exactly what it’s doing. Mum’s description was “a lot of text on the screen”, which I took to be a kernel panic, which I’d witnessed last time I visited. In fact it’s repeating over and over “I/O Error”, confirming the HDD is most likely toast. Still thinking to try clone it onto the new drive, though concerned that may result in corrupted data.

After removing the HDD from the ATV and sticking it in my Dock, sadly I’ve confirmed the drive is dead - wont spin up. As such - corrupted data wont be an issue - can’t get any data from it. Thankfully the media stored on the drive, plus all the cover-art files are on a backup drive!

Looking online, I’ve found some “back ups” that other people have made available of the ATV’s 3 partitions - EFI, Recovery, OSBoot. As such will try the app, ATV Cloner, to instal them, as it apparently takes care of all the specific partitioning requirements.

Actually, I’ve just found a site which suggests installing the “recovery” partition onto a USB stick, then restarting the ATV so it will boot from that drive and perform the recovery function. Tried it out… failed. I know the ATV is quite fussy about which USB sticks it will or wont work with… so tried again on a USB stick that I know the ATV likes (used previously for installing ATVFlash) - but still no good. Back to ATV Cloner.

Tried using “ATV Cloner” app to instal the partitions onto the Toshiba. Installed the drive into the ATV with the ATA->SATA card (HDD just sitting loose on top, as the base no longer fits back on), booted up, but - “flashing question mark” error… Checking the partitions with Terminal, they aren’t set up correctly - doesn’t have the correct number of partitions for what it needs… Not sure if that’s my fault or the app… Looks like I’ll be heading into Terminal next…

OK - wasn’t that scary after all. :slight_smile:

Followed the instructions here:

http://wiki.awkwardtv.org/wiki/Prepare_a_Hard_Drive#Acquiring_the_necessary_images

As I already had the dmg files, I skipped the first part, moving onto the partition section. There were at least 2 lines of commands where I had to add “sudo” at the start in order to make them work. The instructions state to hook up and do the factory restore (twice!) - however if you copy over the OSBoot dmg, you can skip this. Partitions now look good! Just need the kids to get off the Wii in order to test! :slight_smile:

So far, so good, I think.

Hooked the ATV up again to the tv, and it booted up and got to the “restart/restore” screen. I chose restore, thinking it probably wise to start afresh (given I don’t 100% know that the OSBoot dmg is completely stock, as it was downloaded from the net) - however the ATV “failed to restore” when requested despite several attempts. Instead I opted to restart, and it flawlessly booted to the “desktop” (menu screen).

I am a bit concerned that the restore wouldn’t perform its job, in case I need to use it at a later date… Not sure why it “failed”… But for now, will proceed and attempt to instal ATV Flash, and copy over the 600-odd gigabytes of Doctor Who for my brother.

Also @The_Hawk picked up the Dremel 200 for $69 from Bunnings :slight_smile: Ready to start cutting as soon as the part from China arrives.

Hours of mucking around this afternoon / tonight… Installed FireCore ATV Flash without any issue using the faithful USB stick, however after copying over a test video file into the “Movies” folder, it failed to play - “An error has occurred” every time. XBMC also would not download - same error.

Still can’t perform a factory restore, which I am wondering if may be a symptom of the problem…

Will start over tomorrow.


#17

Started over, complete process again - Partitioned the drive, copied over EFI and Recovery dmg’s. Decided not to copy the OSBoot dmg - instead will try the “restore” option again, which simply copies over the OSBoot file found in the recovery dmg. However (!) - despite having uses these commands:

diskutil unmountDisk /dev/disk2
sudo gpt destroy /dev/disk2
sudo gpt create /dev/disk2

… and NOT copying over the OSBoot dmg (ie the System/etc) the ATV booted to the menu screen… and it remembered all the ATVFlash instal, etc…!

And - after adding a folder into the Movies folder, and a test video file - success! Played without issue.

I’m guessing that the data that was on the OSBoot partition was not actually over-written, and simply remained in place despite the partition creation processes. At any rate - will upload some more test files and watch a few of them to make sure it’s stable before handing back to my brother - not to mention needing that part from China, and learning to dremel so I can actually (hopefully) close the ATV back up!


#18

Update

The AppleTV has been acting about as “normal” as it’s ever been - which is to say, sometimes it runs nicely, other times it may sit for a minute (literally) and not move, then suddenly “catch up” with any button clicks. I recall this being an issue before I ever jail-broke the device however. It also sometimes freezes hard and requires a restart. Again, not uncommon.

I’m still baffled by the inability to run the “Factory Restore” - this was happening both before and after the FireCore instal. On the FireCore forums it appears others have this issue - though more related specifically to after the software instal.

As per above I’ve moved on, hoping for the best, and begun to instal the media onto the drive. Have filled about 300GB so far… Have lots of shows from our childhood that I think my brother will enjoy - just going to be a pain to navigate, as setting them up in their own folders didn’t tend to work last time (he would only go into the first folder - Doctor Who - and need mum to direct him into the other folders). As such every file is simply in the same directory… 262 episodes of Doctor Who (with 2 more Doctors to go!), The Goodies, X Files… and lots more I can now afford to instal thanks to the 1TB HDD! :slight_smile:


#19

Has been a good few weeks now, but the media is fully loaded, cover art matched up…

I’m still a bit concerned with the machine’s performance - temporary freezing, crashes etc. I read that the thermal compound on the CPU should probably be replaced if you’re already inside the box, so today I went to Jaycar (with 3 kids in tow - yay) and picked some up. Wait for little one to have his nap… then follow the remaining steps to fully dismantle the ATV1…
Except - whilst trying to disconnect the IR cable, the clip broke! :frowning:

I’m hoping that although the plastic clip is damaged, the wires are still in place (hard to tell) and will operate… Otherwise this is going to get really frustrating!

(Luckily - before I began by chance I received a text from my older (oldest) brother. He has dug out his ATV1 that’s been sitting in a cupboard for years, and he’s going to leave it with mum next time he sees her. So there will be a “spare” on hand if required…)

In the end, I opted to forget the thermal, and just went ahead with the required dremel-based operations - Cut off the screw-post in the corner of the base plate, and cut the “rail” in half to make room for the ATA-SATA adapter card. (And I still have all 10 fingers! Woot!)

BTW - I’m using this adapter:

https://www.ebay.com.au/itm/2-5-Male-44pin-IDE-To-22-Pin-Female-SATA-HDD-SSD-Adapter-Converter-For-laptop/132472597601?epid=788888274&hash=item1ed7fb6c61:g:utIAAOSwZd1VX-nI

The other card had too much height.

Few notes:
*Had to re-fold the ATA cable in order to get the HDD into a suitable position.
*Could not screw the HDD back into the base plate with its mounting screws because the hdd is in a different position now.
*Required a degree of manipulating to get it all back together, and the base plate does not sit 100% perfectly - ie the corner where the HDD sits is bulging a little due to the lack of screw and the re-arranged innards.

Will be able to test it all out later tonight, but here’s hoping it works. :slight_smile:


#20

Its good to see you got a bit further with this project.