14.5.1 Update Failing

My iPhone 11 Pro Max does not want to update to 14.5.1
Going into software update on the phone starts searching for the update, then sort of half loads the screen before crashing.

Trying to do the update through iTunes extracts the file, backs up the phone then ends with this error:

I’ve tried rebooting before trying either method with seemingly no solution… has anyone else seen this problem?

I got that same screen.

I clicked “Download and Install” and it’s been spinning its wheels for a few minutes…
Now saying “Update Requested” for a while…

I will edit this if there’s any advance, though it’s not crashing, so sounds like we may not have the same behaviour.

Good luck!

Edit: I let the screen switch off and when I woke it the update was ready and proceeded without taking me back to the Settings app.

My 12 Mini updated within a few minutes and everything seems ok. Hope you get your issue resolved.

Still borked this morning. I’ve just delete am re-downloading the update on the computer to see if that helps.

It took me a while to find where it’s saved in 2021 on Windows and ultimately had to find it by running a manual search for ipsw files. Turns out it’s here in case people are looking for the save location:

C:\Users<USER>\AppData\Local\Packages\AppleInc.iTunes_<RANDOM>\LocalCache\Roaming\Apple Computer

UPDATE: While I was waiting I tried to do the update on my Wifes M1 Macbook. It seemed to want to start the same 6GB download, but then said it was doing something with a countdown for a few seconds… then popped up telling me that the software on my phone was corrupt and to unplug and try again. OK then…

It is worth noting that it’s been a long time since an iPhone has been plugged into a computer (for anything other than tethering) since it’s just not needed anymore. This iPhone (11 Pro Max) has had every update as they have come out so hasn’t missed anything along the way.

By this time my Windows computer had finished its re-download so armed with that new information I figured I’d try again on this machine while the Mac downloads the full file. Plugging the phone in and hitting update started the usual dance, but then I got the disconnect chime…

Was this working? Was the phone re-booting?

Sort of. I saw the recovery mode screen for a moment before it flash over the the Apple loading screen with the progress bar with iTunes telling me that it was verifying the update…
then Updating iPhone software…
then Verifying updated iPhone software…

then Updating iPhone firmware???
Verifying updated iPhone software…

It’s been a while, but I’ve don’t remember it taking quite so long or showing so many steps along the way.

Your iPhone has been updated… you phone will reboot

One progress bar and an apple logo later, it’s back up and running on 14.5.1

I’m not sure if the Mac kicked it just right to do what it needed to do? In any case, it appears to have worked. I had zero issues on my iPad that I did just before trying the phone last night either.

I saw the same Software Update page in my 12 Mini. I think I saw it elsewhere too on my partner’s iPhone 8. In each case I scrolled down, saw Download and Install, hit that and the update proceeded okay.

There does seem to be something going wrong with the Software Update page

Same issue here, set the phone to auto update and let it sit overnight plugged in and it downloaded the update and after a few tries managed to press the install now button and it all went through.

Definitely something broken on the update page.

I definitely think there are issues with the update, although I did get it to work