AirPods - weird issue, weird resolution

My AirPods Pro started playing up this week. At home, they would connect but sound continued to output from the iPhone. I installed iOS 14.5.1, no change. I unpaired and re-paired the AirPods, no change. Even weirder was that I was not having any issues using the AirPods at work. This morning at home, again they wouldn’t work. So I continued googling and trying a few things, and then something worked.

From home I called my work phone, the dial came through the AirPods. I ended the call then tried to play Pocket Casts and RadioApp and voilà, sound coming through my AirPods at home for the first time in three days.


1 Like

I experienced this today, iPhone 12 mini on 14.5.1 and AirPods Pro on 3E751 (the new AirPods Pro firmware which came out recently - not sure when mine updated) - some magic combination of remove airpod, replace airpod, open and close case, pause and play got them going again.
Will monitor closely


Mrs entropy had similar problems and had to re-pair to her XS Max. I suspect an issue with the iOS update.