Do Not Disturb is disturbing!

I have been having issues with DND simply letting some calls through. Anyone else? I think its only been since iOS14, but cant be certain. I’ve had to “silence unknown callers” yet again, and hope that genuine callers will leave a message. Its annoying to be woken when I am having a much needed nanna nap.

I’ve checked settings and everything is/was as it should have been, to not let calls through. Anyone else?

Probably a silly question, but the numbers aren’t set for emergency bypass are they?

What are your other settings:
Allow Calls From ??
Repeated Calls ON/OFF ??

No emergency bypass

Allow calls from noone, repeated off.

What about the silence option? Is it set to always, or just when the device is locked?

Next stupid question: if it’s set to when the device is locked, are you leaving your device unlocked when you have a nap?

I have to have it on silence all the time, because I use Sleep Cycle to keep track of my naps and sleeps… and that requires the device to be unlocked.

Its a puzzlement.