External disk won't mount

Last time I accessed the external drive (with the complete backup contents of the HD running Sierra) I must have shut down without ejecting the disc first.

Now the computer tells me ‘Disk not ejected properly.’ As soon as I click on the disk icon it vanishes. I selected it in the sidebar, where it was greyed out, and ran Disk Utility > First Aid. It completed the process, still greyed out, and told me the disk is unmounted, which I knew.

I’m using the same cable as before so it’s not an insufficient power issue.

  1. How can I fix this? I’ve searched the ‘net in vain for hours. I don’t want to reformat it. I’ve kept it ‘as is’ as some apps don’t run on High Sierra.

  2. Can I safely disconnect it from the computer without doing further damage as there’s no option to select it and choose ‘eject’. ?

Thank you for any help.

EDIT: Found that it was safe to shut down, then disconnect.
Would sincerely appreciate an answer to 1.

Tried a new cable?

Thanks kyte. No, don’t have another cable on hand.

Today I reconnected the external drive. It mounted and stayed on the desktop and I was able to open it. When I tried to Eject it kept telling me it couldn’t be ejected because the Finder was using it. It wasn’t.

On about the 5th or sixth try it vanished from the Desktop so I was able to unplug it. It’s probably because the old HD (which it is) takes longer than the new HD (which is SS) to shut down so I just had to wait.

I don’t know why it wouldn’t mount and stay there yesterday…same cable and it had plenty of time. It showed up a couple of times but vanished as soon as I clicked on it. Thanks again.

If that happens, when you’re trying to eject, the best advice I can give you is to shutdown the computer. When it’s off, it’ll be safe to remove, especially if the drive is temperamental.

And on that, absolutely a good time to clone it to another disk… They’re not that expensive these days and it’s going to be way cheaper than data recovery.

1 Like

I would add… depending on your set up… the internal mechanism may well have many more years life - in my experience it’s the case that dies.

Pop the drive out and use it elsewhere…

Thanks, adamd and cosmichobo.

I found the information about safely disconnecting the drive after shutdown on-line and edited the first post accordingly.

It’s really only a secondary backup as it’s the original HD from my 2012 MacBook Pro. and its data has already been transferred to my laptop onto its new SS drive. That was done when the old drive started misbehaving early this year. That is backed up regularly to a new Seagate backup disc.

The case might be tired. Because of supply issues when I had the new drive installed in my laptop the case that had also been ordered did not arrive so the technician gave me his.

Thanks again for the advice.