Safari not loading some websites properly

G’day all

Been quiet on here lately.

I use Safari almost exclusively. Recently I’ve found a few websites that just don’t work with it however and have resorted to Firefox to get the job done. All my software is up to date.

Some examples:

The Register button did nothing with Safari.

Team selection buttons flicker and don’t always register selection properly. Rock solid behaviour in Firefox.
The form wouldn’t load in Safari but did in Firefox (but I just tried it then and it worked in Safari).

Anyone else notice Safari misbehaving a bit of late?


Are you using the most recent version of Safari?

15.4. “All my software is up to date”

I have had a Safari issue for at least 6 months. When I first click on a link, a new tab opens, but the site doesn’t load. If I close the new tab and click on the link again, the site loads quickly and without issue.

It does not happen that often, so I am yet to investigate it.

Works for me… I am on a 2012 MBP, using Safari 13.1.2

Works for me today as well. Weird.

1 Like