Stocard stopped working on Watch

I’ve been using Stocard extensively on my Apple Watch (series 5) but since the last OS updates, its stopped doing anything except showing a spinner and “Loading” which never completes.

I posted in Whirlpool but in spite of lots of views, no responses, I’m guessing nobody else is having problems, or else everyone is and just looking for an answer

I’ve deleted the app and reinstalled it, I’ve rebooted both devices and no joy.

Anyone else or is it just me, needing to find an alternative?

Working here for me.
Watch 5, watch OS 7.02, IOS 14.1 on XS max.

1 Like

Thanks fr the reply. Is that the 14.1 beta? I’m on an SE2020 but 14.0.1 is the latest I can get.

Maybe unpairing, and re-pairing might help. Havent gone that far yet. I did find an alternative in something called mobile pocket but it doesnt show up as a complication so I can’t add it to the screen and instead added it to the dock as a favourite. Not as elegant as Stocard.

I’m running an iPhone 11 Pro Max and a Apple Watch Series 5. I didn’t even realise there was a Watch App for StoCard as I tend to use my phone for that… maybe that’s going to change!

In any case, I’m using the latest retail versions of iOS (14.01) and Watch OS (7.02) and I just opened the app on my Watch and it was there instantly and the cards came up when I selected them, so it appears to be working fine for me.

Have you tried turning it off and on again? I never reboot my watch as a matter of course, but I suppose that everything chucks a wobbly from time to time and needs a reboot…

Plan B: I would delete the app from your Watch then re-install it since that’s the easiest option. After that I’d be looking deleting and re-installing the app on the phone (and watch at the same time I suppose)…

Beyond that you’re into full refresh of the phone, but that’s getting pretty extreme and it shouldn’t come to that.

Yeah, as said in my first post, I have done all that. I have even re-paired the watch and used a backup which I know was working with Stocard. No change, its still misbehaving. I don’t want to have to refresh the phone but theres not much left. I’ve sent a support request to Stocard in case they might think of something I havent.

[edit] I was just sitting here contemplating resetting the phone, whch would then mean re=pairing the watch, organising all my cards in Wallet, blah blah… and I think if I cant find a solution I’ll just carry on with the current replacement. The thought of having to do it all again just fills me with horror.

I can’t remember the last time I even opened Stocard on my Apple Watch Series 4, but I just did then and it works fine for the two cards I have in there (that I don’t remember adding, either).

I’ve got my flybuys and woolies cards in there, but also library cards, petstock and Petbarn, Club Ted, yada yada. I dont use any very regularly these days, I guess I could leave most out of my wallet and out of stocard. I did have woolies in Apple Wallet at one time, cant remember why I took it out.

I seem to remember hearing/reading about an app that could convert any card to be accepted in Wallet… what was that, anyone remember?

Yes, 14.1GM. Should be out soon.

1 Like

Well Stocard support was no help, did not expect that it would be, given that the issue seems to be mine alone. So this morning I have gone the whole hog, unpaired watch, reset phone and set up as new rather than use a backup, in the hope that whatever was stopping Stocard from working will now not be present. There were other anomalies as well, for example, watch faces kept disappearing when I was wanting to choose one… it was truly weird. Right now, I’m in the throes of updating everything. and, after all that… NO FUNCTIONING STOCARD!!! ARGHHHHHHHHHHHHHHH!!!

I give up. Deleting.

[edit] Prior to deleting, the watch face gallery kept doing what it was doing yesterday, ie, disappearing faces… and aftr I deleted Stocard… they are all behaving as normal. Clearly, someone up there does not want me to use Stocard.

OK, I think I have it sorted.

  1. I was using my iPHone7 for a while as I needed to take the SE to a genius to clean out the charging port (I couldnt see what was in there but they fixed it)

  2. Apparently when unpairing from the iphone7, the unpair was incomplete.

  3. Getting back to the iPhone 7 and re-pairing has solved the issue. Stocard works, so does everything else.

  4. I was planning to sell the iPhone SE 2nd gen ahead of buying a 12 of some kind but had decided to wait. Its ready to go now, so I’ll sell it and stash the cash til I am ready to buy. The 7 will be fine for now.

That sounds odd, but if it works maybe it’s best not to ask why.

In theory, Stocard syncs from the cloud so shouldn’t matter if it’s on multiple devices (we have the same account on my Wife and my phones). The Watch should care (or know) what else it used to be synced to once it’s wiped either.

I’ve also just checked and my wife’s iPhone XS is paired with a 3rd Gen watch, both running Stocard happily on the latest (retail) versions of iOS and Watch OS so it’s not like you can only connect a single device.

That said, I know I have had issues transferring from the old iPhone to the new one and keeping the Watch working, sometimes that has required a re-sync of the watch, but I don’t recall what I did last year on that front.

The thng is, I dont thnk it can have been wiped. I got a message that it was not properly wiped so I’m assuming Stocard was caught up in that. If the watch thinks its supposed to be connected to one device for Stocard, then other devices wont work. anyway, its working fine on the iPhone 7 right now, and watch5 is happy