4K monitor - can't get 3840x2160 setting


#21

Not all Mini DP-DP cables are made the same. I bought a Cheap one from MSY. Quite often when I plugged in my Macbook Pro to my Benq GW2765 2560*1440 monitor, the Mac wouldn’t “see” the monitor. Get the Macbook to “see” it, I had to plug in a HDMI cable (lucky I have a HDMI port on my Macbook). Anyway I got hold of a more “expensive” cable from work, and lo and behold it’s flawless, the Mac sees the monitor every single time.


#22

So the Alogic miniDP to DP arrived today. But still having the same issues. Went through all the available scaled resolutions and with the exception of the 1280 x 720 it was a very fuzzy image. Even the 1152 x 648 which suggests to me that its not the cable. Anyone have any other suggestions?
Are there any tests i can do to see if its a faulty port or graphic settings?


#23

This is beyond me so please ignore if you like.

Have you checked the menu options on the monitor itself? Is it set to PC and not AV? Or something like that?


#24

Sure. Got another 4K display handy, or another device that can output 4K?

Seems unlikely that two cables don’t let you do 4K @ 60Hz.


#25

Your iMac is capable of up to 3840 by 2160 pixels at 60Hz externally according to Mactracker.

When you choose “default for display” then switch back to “scaled” what does the Mac select? (i.e. this will tell you what it thinks the monitor’s default is. It may be using a ‘retina’ resolution. Is one of the “looks like” resolutions “1920x1080”? That’s the physical dot size that a ‘retina’ display will show for 4K in an iMac.

Also, what exact model is the display? I couldn’t find anything for U28H75x - but at a guess it’s a 28 inch? If so, 4K isn’t going to look like retina. It’ll be close, but not true retina. 4K ‘true’ retina (i.e. so you can’t see pixels) is at a physical size of 21.5-inch (i.e. iMac). It’s also possible (and totally dodgy) that maybe the monitor’s circuitry won’t do full 4K on the display port? Check the manual.


#26

If this is your monitor, check the OSD for this setting to make are you’re running Display Port 1.2 or greater:


#27

Thanks for all the replies.

Ive tried the monitor on my pc and it operates perfectly at 3840x2160.
When i choose ‘default for display’ and then ‘scaled’ it highlights '3840x2160’
It is a 28inch 4k LU28H750UQEXXY, the DP works at full resolution on my PC.

Ive tried both 1.1 and 1.2 settings on the monitor and that doesn’t seem to make any difference.

I’m starting to suspect that the error is with my mac, my latest thinking is it might be some kind of fault with the mini DP ports. There are two mini DP ports on the back and interesting when i switch which one i plug the cable into they give different displays. One is very fuzzy, the other is absolutely terrible.