Auto-Play HTML5 Videos In Safari


I am going mad. A lot of news sites these days have auto-play videos that pop up and start playing. I find them extremely annoying as I am usually listening to music on iTunes while reading these sites, and the audio component is frequently much louder than the music I am playing.

The worst sites in my situation are The Sydney Morning Herald website, The Daily Telegraph website, and Yahoo7. These sites all have auto-play videos. I even saw one page on The Daily Telegraph site that had three videos playing at the same time. They are not advertising videos, they are about the content that I am reading on the page. The first two I have a paid digital subscription to, and with the SMH site you can set preferences not to play the videos, however half their pages do not have a log-in option e.g. business pages, and these pages play the videos.

Apparently in previous versions of Mac OS you could turn the videos off in the Accessibility options. You can no longer do this in Mac OS Sierra.

I now have to listen to music on iTunes Match via my iPad so I can keep the sound on my MacBook Pro muted. It is not ideal.

My question is: has anyone seen a solution to this problem? Reading other on-line forums people in the US are getting the same problem on the CNN website to name one.

I have heard that other browsers can block the videos e.g. Chrome and Firefox, however I do not want to lose the bookmarks syncing with my iPhone.


I use Chrome, and I know you said you don’t want to use it.

There’s an extension I installed which stopped autoplay, mainly due to Fairfax autoplay. It’s not bad, but I ended up disabling it as it stopped YouTube, iView and Netflix videos from playing without intervention. There was a whitelist option but it was very convoluted.

No idea for Safari sorry.


How about if you use reader view, I think that stops videos playing.


From this morning’s news:


Yes I found this a couple of days ago and I have been testing it out. One modification I have made is to only activate “Audio needs user action” in the Media Flags section. With this setting the video loads but does not play, so if you do want to watch it, you just click the play button and it will play normally. If you check the “Disallow inline video” option all video is blocked and you will need to uncheck the option if you want to watch the video. I only wanted to stop the autoplay so the first option works perfectly.