Auto unlock MacBook Pro with Apple Watch 2 doesn’t work and is frustrating


#1

That’s all I’ve got to say.

It’s hit and miss.

Once it works, it’s amazing, and I would sleep the MBP for fear of losing the magic. But the moment I am forced to restart, I would lose this magic.

Lately, I haven’t been able to make it work again, no matter all the tricks I’ve tried after googling online, including restarting everything (including in different sequences), logging in and out of accounts, etc.

Is this happening with anyone else here?


#2

And mysteriously, it has just started working again. With no intervention. What is going on…


#3

After a restart I have to enter my user password to unlock. When it wakes from sleep auto unlock has always worked.

Or is your issue that auto unlock does not always work when it wakes from sleep?


#4

Every now and again that happens to me. Turning bluetooth off and on again on the Mac seems to do the trick.


#5

It just doesn’t work from the start. But after a while, mysteriously would randomly work. Hard to know why - no pattern so far.

Have tried that and other things - doesn’t seem to make it happen.


#6

My Series 0 watch unlocking my MacBook Air has worked perfectly until tonight, and started exhibiting the same behaviour you described.
I didn’t have the time to troubleshoot it tonight but I was shaking my fist in your general direction :stuck_out_tongue_winking_eye:
.
.
.
.
edit And tonight, having not changed a single thing, we’re back and working reliably.