High Sierra with Low Expectations


#21

I’m seeing this with some client iMacs at the moment since they ‘upgraded’ to High Sierra 10.13.3 - they are all 2015 21.5" iMacs and I’d like to look at upgrading them to SSDs but given the time it would take to get in to the thing to put an SSD in it I wonder if it would be worth it. The only iMac I’ve worked on in the past was a 2008 (ish) 20" and it was a bit of a long winded process to take apart.


#22

I honestly can’t believe Apple can put 5400rpm drives in $1500 computers in 2018.

It annoys me that they either have to put in the slowest possible technical harddrive, or they have to put in a mSata SSD. Surely they could put standard SATA SSDs in and save a lot and have adequate performance.


#23

As long as you buy tools and kit of adhesives to put them back together, it’s actually an easier upgrade I reckon than the 2008s. Having the glass and display in one piece makes it WAY easier to get back together - as you don’t have to spend 20 minutes getting every last speck of dust out from under the display.


#24

I’m just about done with High Sierra. I can see no appreciable difference between it and Sierra in day to day use, and I went from a totally supported GTX 660 to a pixelated nightmare. And I’ve waited and waited and waited for a fix either from Apple or NVIDIA and it hasn’t come. So finally, yesterday, I decide, okay, I got paid a week early, I had just paid the deposit on a new place that is cheaper by $150/mo than my current one, and that’s just the rent, my new place includes everything (gas, electricity, parking, and internet), and I thought, okay, I’ll get a 9-series or a 10-series if I can find one. So I got a GTX 950…

And now while my main 4K monitor has no issues, I have no ability to use my DVI-VGA for my projector! So instead, I am running the GT 710 (which also runs fine under Sierra) for its VGA port, but it’s slightly choppy. Watchable for YouTube and present day TV shows, less so for something like Star Trek Discovery.

I can’t win with High Sierra, and since it’s almost certain 10.14 (or maybe they’ll go up to macOS 11) won’t be compatible with any kind of hacks like Sierra and High Sierra, I gotta be honest…

I think I just have to downgrade. Will I really miss anything if I do?

EDIT: I see 10.13.4 will drop shortly. If this does not fix my issue, I am going to back to Sierra.


#25

El Capitan the 11.6 update is a bit of a bugger too.

It took forty minutes to do what it needed in the reboot phase which on all previous updates (on El Capitan) took somewhere between 3-7mins. I’ve been trying to avoid updatin to the current OS as it’s rubbish in comparison.


#26

Apple has finally acknowledged the “Too many corpses being created” issue in High Sierra. The fix involves removing some Open Directory caches.

  1. Restart the computer and boot to macOS Recovery. (Command + R.)
  • If FileVault is enabled on the startup drive, open Disk Utility. Select the startup drive, click Mount in the toolbar, and when prompted select a username and enter the password to unlock the volume.
  1. Open Terminal. (Utilities > Terminal.)
  2. Type the following command:
    cd /Volumes/Macintosh\ HD/var/db/caches/opendirectory/
  • Replace Macintosh HD with the correct volume name if it differs. Remember to use an escape (backslash, \) before each space in the command path.
  1. Press Enter \ Return.

  2. Type the following command:
    mv ./mbr_cache ./mbr_cache-old

  3. Press Enter \ Return.

  4. Quit Terminal and restart the computer.


#27

This would have been very useful 5 weeks ago.


#28

Remember, there’s “nothing wrong” with an Apple product until enough people have the issue. First responders are never trusted, only once critical mass is achieved does it become accepted and no-one ever apologises to us!


#29

So true. I had to do a complete erase and reinstall for a client… wasn’t fun.


#30

Stab, stab turn stab.

High Sierra (10.13.4) on my Mac Pro 3,1 has in the last few days started having kernel panics constantly for no apparent reason. I ran through the general trouble-shooting one does. No new software or installation that would seem to have caused it, .4 has been out for a while, different app in the report each time, Windows 10 doesn’t do this at all. Doesn’t matter if the installation (cloned) is on an SSD or a spinner drive. Panics happen anywhere from after a few minutes to a few hours.

If 13.5 doesn’t fix this, that’s it, I’m downgrading to Sierra. This is ri-DONK-U-lous.