High Sierra with Low Expectations


I’m writing this post to share my experiences, provoke some discussion and possibly offer some advice on macOS High Sierra and a number of recent reliability issues we’ve been encountering with it.

The operating system doesn’t seem to be handling its updates well. While software issues happen from time to time, it’s unusual to have six machines on the bench all at once exhibiting the same or similar problems, with the only common denominator between them being macOS 10.13. These machines are different models, from iMac to MacBook, from different locations around South Australia, some connected to WiFi and some connected to Ethernet, some accessing the internet via NBN and some via ADSL2+.

The computers stop booting after installing software updates. When booting the machines in Verbose mode, the computer repeats the same message indefinitely:

Process [x] crashed: opendirectoryd. Too many corpses being created.

Apple has not acknowledged the issue and has not offered any solution to it, but reinstalling the OS does not resolve the problem. The only surefire solution is to backup the volume, erase it, reinstall macOS and migrate the user data from the backup.

In the process of reinstalling the OS and reapplying the software updates, the computer can sometimes fail once again with the same issue if for whatever reason the update once again does not install successfully.

Because many Apple computers are configured to automatically install updates overnight, some customers return in the morning to find their machines unusable.

But it continues. I’ve installed the 10.13.3 delta update on some machines only to have the machine freeze on restart at the Apple logo, before the process bar appears and thankfully before the update starts installing so a hard reset allows the update to continue normally.

Overall, the issues in High Sierra seem to vastly outnumber the issues in its predecessors. Sierra is a dream in comparison. El Capitan not as much, and then Yosemite and Mavericks before it were also decent systems to use. (I’m still running Yosemite on my own machines, where security is no concern.)

Of course the machines out there running High Sierra that work fine never come in the door, so I never see them, only ever the ones that failed. The volume and consistent patterns of failed machines I do see that happen to run High Sierra however paint a troubling picture.

I hope whatever version comes next addresses some of these issues. At the moment, Sierra is still the version of choice, or Yosemite on those older machines without support for it.


3 Macs in this house, all running High Sierra, 2 of them running the latest public beta of 10.13.4.

I’ve not experienced any real problems, so I would suggest that perhaps you re-download High Sierra and make a new USB installer, do fresh installs on the Macs in question, and restore from backups.


Already done, around three machines today alone but expecting more for the foreseeable future.

It seems to work, but I’ll continue investigating further because this too many corpses being created error is becoming more common, and as the volumes increase a better solution than a tedious backup, erase, restore and migrate is needed.


No problems here, I am using a 2017 iMac.


I love how every time someone mentions an issue with High Sierra everyone feels the need to chime in and tell us it’s working perfectly for them.

@iMic I totally feel your pain. 10.13 is the buggiest release of macOS in years. I see heaps of issues every day. From little bugs that weren’t in previous versions (like Messages not matching phone numbers to people the way it does on iPhone, especially around +614 vs 04 at the start of a number) to big issues like APFS external volumes not mounting and appearing like the last disk image mounted :man_shrugging:.

We get it. It works sometimes. So does Windows. But 10.13 doesn’t work a lot of the time for a lot of people. We’re not making it up. It’s a little offensive to be told every time we report an issue that it “works fine here”.

By the way, I’ve been professionally supporting macOS / OS X since 10.0.0. This is up there with 10.5.X and 10.10.1-2 in terms of “stuff they rewrote is seriously broken”.


I wonder if you could rebuild the user directory instead of a full reinstall?


I do some contributing in the Video Pro forums and my observations is that there is more grief with users after upgrading to HS than previous OS systems.

That being said there has never been an OS upgrade where someone wasn’t put out for whatever reason, real or imagined. :smiley:

Currently we see Canon video camera users with a strange visual glitch in their footage when using FCP X 10.4 on HS.
Have no idea why and nor does anyone else at the minute.

My own system seems stable and does what the Mac designer intended.




Are you seeing any correlation between machines with SSDs, which get updated to APFS, and machines running rust, which don’t?

I’ve also seen that too many corpses error reported somewhere OMM, though I can’t remember the context. Possibly in an EtreCheck report?


I’m so over High Sierra and its bugs. Was setting up a BRAND NEW Mac Mini for a relative last week and before I migrated any data, I updated everything and it got stuck updating. I’ve had enough grief with it on my own machine as well (@jaysee - have the same iMessage issue which is driving me crazy). I’ve had my share of APFS issues as well.

@iMic Then one of my clients had the “too many corpses being created error” on a 4-month-old iMac. Just stopped booting and I tried everything (reinstalling high sierra, SMC reset, NVRAM reset, safe mode, single user mode, disk utility repairs. I’ve seen a lot of reports on it online. I ended up having to do a clean install and started from scratch.

I’m surprised at your El Capitan comment though - I found El Cap to be more stable than Yosemite and about the same as Sierra.


Yeh I agree - El Cap was solid for me, more so than Sierra. If anything as the last “old world” Mac system, it most reminded me of Snow Leopard actually.


Yes me as well. My most stable (at least in my experience) were Tiger, Snow Leopard, Mountain Lion, El Cap. Sierra and Yosemite (at least the later versions) weren’t bad.


The problem with El Capitan was that it performed incredibly slow on machines with traditional HDDs. iMacs were the most commonly affected machines for this reason.

We had machines coming in with 10-15 minute boot times in extreme cases, and issues with Spotlight constantly indexing were fairly common, with no clear resolution. The machines were unusable at times because of it.

On SSDs it was a much better performer, but still not as quick as some of the releases that came before it. macOS Sierra seemed to correct whatever caused the persistent indexing (although I’m not sure how or why, but we certainly saw significantly fewer cases of that particular issue over time), and earned a somewhat better reputation in our book.


Oh - yeah, that was TOTALLY true, although I noticed that started with 10.9/10.10.

I’d forgotten as everyone I support is on SSD these days. :slight_smile: Have spent the last few years upgrading them instead of buying new iMacs… even on brand new iMac 21-inch, those HDDs are PAINFUL. Makes upgrading an old one a no-brainer.


Actually now I remember - i had endless issues with my MacBook and El Cap with spotlight not indexing. However, El Cap was my go-to OS for older MacBooks (mainly 2009 and 2010 MacBooks), with HDDs, as it was faster than Sierra, and more stable than Yosemite.


Has anyone had issues with external USB and or Thunderbolt drives “not ejected properly” for no apparent reason.

I’ve recently experienced this along with some other users.
I’m listening…particularly if there is a known cause/remedy.



I’ve got 6 external thunderbolt drives and none of them have reported ‘not ejected properly’ with any version of macOS I’ve been using since Mountain Lion


Thanks for the feedback.
I’ve clean installed HS, so from here on expecting reliability!!



Yep - seen it on multiple machines, but as below, it’s usually a hardware issue - dodgy cable in most instances.

As was I. I was sorely disappointed.


I see this from time to time on all sorts of OS/Hardware. Usually it’s due to either dodgy enclosures or corrupted disk partition tables. Not usually a software issue in my experience.


Good info, thanks.

I recently had my old editing Mac die and have upgraded.

As a consequence: also decided to clean/back up my external drives.
I can report that after juggling a few terabytes, all is well. Maybe the clean install helped. Anyway, a lot of dross is deleted from my new machine.:grinning:
Double checked cables and sockets.