iCloud Pword change - Mavericks - Help

#1

G’day,

The other day for reasons I have forgotten I had to change my iCloud / Apple ID password.

Ok, done.

Next, every Mac and iOS device asked for the new password- and also then for a code via one of the other devices- Apple’s new 2 step sign in.

Great - except - it’s f’d Up on Mavericks.

After asking for the password, it says to enter the password and code from the other device - except it doesn’t offer a dialogue box to actually enter them!

So now both Mac devices on Mavericks constantly ask for the password, but won’t let me complete the process…

:confounded:

I would just sign out of iCloud, but it warns you a dozen times about how data will be deleted and that puts me off after previous iCloud data loss experience…

Is there a work around?

Cheers

cosmic

0 Likes

#2

Have you tried rebooting both your Mavericks machines? I know you probably have, but just putting it out there.

Its a NIGHTMARE changing the pass now. I made the mistake of changing mine to a really long and complicated one that I will never remember and so every time I need it, I have to open my password manager and copy. Wish I had never.

0 Likes

#3

Do you mean - “have you tried turning it off and on again ?”

:nerd_face:

Not yet… :grinning:

0 Likes

#4

On devices that don’t support 2 factor authentication, you need to enter your usual password, then enter the two factor authentication code on the end of your password.

Why are you still on Mavericks though? El Capitan & High Sierra are far more secure and stable. Unless you’re not on an SSD.

0 Likes

#5

Ahhhhhhhhhhhh - ok. Gottit.

Thank-you!!! :slight_smile:

No SSDs in my house yet… I did upgrade to High Sierra on the MacPro5,1, however then I was unable to use FCP7, and FCPX couldn’t do what I’m currently working on, so I retrograded… Though in retrospect, I am going to look at bumping up to Sierra, which I understand does allow FCP7 to run.

The other machine that’s running Mavericks is a 2009 MacBookPro, aka Netflix machine. Not sure how it would go on anything too modern as it’s not SSD either, plus being 10 years old… but it plays Netflix fine.

0 Likes

#6

That makes sense :stuck_out_tongue: Mountain Lion and Mavericks were probably the last versions that ran ‘well’ on HDDs!

0 Likes

#7

I just went into the Mac App store to download Sierra, as the last macOS that is compatible with Final Cut 7, and going to be the OS for my newly arrived 500GB Samsung EVO SSD. (yay! excited!)

And just enter the ol’ Apple password, and - rejected. Err, that can’t be right - I entered it correctly. Try again… No. Please reset password. F. F.

There’s no way I entered the password wrong, as I entered it a few minutes earlier to download an app on an iPad for one of the kids.

I’ve now had to reset the password… and will now have to reset every device again…

Thank-you once more, Oldmacs for the clarity offered above. At least it will be less of a hassle, but still a hassle none the less.

0 Likes