Network Issues


#1

I am seriously confused. My devices all connect to my modem/router without problems. EXCEPT for my macbook (2010) which had been fine up until a few weeks ago. I didn’t worry about it much because I mostly use my Air2 in any case. That might seem simple… I thought perhaps the wifi was crapping out in the macbook, but it connects easily to other networks. There are Telstra Air networks within cooee and it connects to them, it connects happily to my phone and to my Telstra wifi gadget. But, it refuses to connect to the local network … a reboot of the modem fixes the problem until the next time.

Any ideas?


#2

Model of Modem/Router? Perhaps its a known issue.


#3

Netcomm NF17acv. But given that only the laptop has an issue, and all otherdevices connect without issue, I would not think its the router/modem. In any case I have reconnected an old but reliable AEBS and switched off the modem’s wifi, and everything seems fine now.


#4

Still could be a fault that only impacts the one client. Probably some sort of software bug with the client itself and only against that type of configuration. Your work around is the best way to address it though.


#5

LOL! Well I sure wasnt going to reboot every time the macbook couldnt connect. That was just ridiculous.


#6

As a starting point, I would delete that network from the MacBook. Then, login to it again and see if the fault reappears.


#7

Lets call that step 1. This should fix the problem if it’s DHCP relater or even if you have defined a static IP that’s clashing for some reason.

Step 2: I’d factory reset the modem. For most people setting it back up is as simple as giving it your credentials for your provider and updating the WiFi settings.

(Repeat step 1 if needed).

If it still doesn’t work I’d probably pick up a cheap USB WiFi adaptor and see if that solves the problem.

After that, I’d consider a full system reformat. Being a 2010 machine you have the option to replace the HDD so you have a few sub options here.

  1. Use a spare HDD just to fresh install the OS, this way if it doesn’t work you just swap back to the original unit.
  2. If you haven’t already this could be the ideal time to do a SSD upgrade.
  3. Maybe it’s time for a clean install anyway??

Beyond that, the next option would be to test a different modem. Hopefully you could borrow one from someone rather than have to purchase a new one.

If you haven’t solved it by this point I’m out of ideas.


#8

All of what ‘The Hawk’ says is good advice but I’d add to it checking the firmware version of the modem to make sure it’s the latest (non beta) version.


#9

Thanks guys, but as said earlier i have got my aebs doing wifi duty and all is well. No furrher problems


#10

I somehow missed that second sentence earlier, go about your business then :smiley: