Networking conundrum

Hi all. I have a networking problem which is confounding me, I hope someone can help.

I’m trying to connect my Macbook Pro to two devices over wifi. My wife’s MBP connects to both of them just fine, but mine just won’t do it, no matter what I try.

But the really weird thing is, I have a powerline-connected wifi range-extender, which sets up a parallel wifi network (same name, with “-EXT” at the end), and when I connect on that wifi network I also can connect to both devices fine.

How come I can connect to the devices over the ‘extended’ wifi network but not the main one? My wife’s can connect over either one. And I can connect to the internet fine over the main one, just not to those two devices.

Specifics:
My MBP: 13" 2018, running 10.14.6.
Wife’s MBP: 15" Retina early 2013, running 10.14.6.
Devices to connect:

  1. A mac mini running 10.13.6. It has File Sharing active with read/write permissions set for ‘Everyone’, using SMB.
  2. A Synology DS413j NAS which I use as a file server and for Time Machine. It’s set for sharing over AFP.
    Router is a FRITZ!Box Fon WLAN 7390.
    D-LINK AC750 Range Extender.

Please can somebody solve this?

Very strange.

I’d suspect something like AP isolation, but that doesn’t explain why your wife’s MBP can connect to the same wireless and work OK (unless there’s some kind of AP isolation exception list, or whatever).

Maybe check if you can reach any other device when you’re connected to the regular Wi-Fi?

Do either of the MBPs use a static IP address or both getting an address using DHCP?

(also try a traceroute to the mini, that might show where the routing is failing…)

The range extender is connected by a powerline adaptor, and you can connect to the 2 devices when your MBP is connected to the extender by wifi, - so the Fritzbox must be the problem’s source in my view.

If there is a filtered MAC address list in the Fritzbox this will only apply to its wifi clients not any wired client connections, - which is what your MBP will appear to be when connected by the range extender over powerline, - and can therefore connect.

Also, when you connect via SMB to the mini, don’t you need to have an account on the mini to be able to connect ? - I use SMB to connect to a Ubuntu linux OS on an HP micro server and I think this is part of the setup, - unless in the SMB.conf file guest OK = yes is set. The SMB default is = No, so unless the smb.conf on the mini explicitly has a line guest OK = yes, then you would need to use you wife’s logon to get access. - But you say you can connect to the mini via the range extender which is not consistent with the above, so this can’t be the problem…:confused:

I’ve found that when I use wifi-extenders, access points, powerlines and other parallel but connected networks that device connection becomes sketchy - I’ve always fallen back to using a very strong single wifi access point, and stick to that or wired network connections.

I assume it’s either IP conflicts or network packet redirection/ rerouting problems.

Aaaand BINGO! You guys are the best!

Yes, once I knew where to look - I dug deep in the router’s settings and found that my standard profile was set to give my computer a static IP address (absolutely no idea how that happened, but there you go). When connected via the wifi extender it uses a different profile, so all good that way. Unticked the static IP address option, restarted computer and router, and all is good with the world!

Thanks so much guys!

2 Likes

Aaaand NO! I spoke too soon. Seems like the router restart causes the problem to go away for a while - somewhere between minutes and hours - but then the connection fails again, and I can’t ping the NAS or the mac mini.
Here’s where I’m at:

  • For simplicity, I’ve turned off the DLink Wifi Extender, and wiped any reference to those networks from my MBP.
  • Using my wife’s computer, I’ve gone through my router settings, purging everything I could find relating to my MBP, and then reconnected it to the network.
  • I can access my wife’s MBP and my son’s MBP from mine, via wifi.
  • I can’t access the mac mini (connected to the router via powerline ethernet) or the NAS (connected to the router via ethernet).
  • The mac mini can’t access my MBP, but it can access the other MBPs. So it’s a two-way blockage.

Here’s the interesting bit.

  • I can access the mac mini when I disconnect it from the ethernet and turn on its wifi, and the mac mini can access my MBP that way. The two-way blockage is not present when on wifi.
  • I can’t do the same test on the NAS, because it doesn’t have wifi.

So the common theme seems to be that there is something blocking the connection both ways between my MBP and the mac mini (and presumably the NAS) that relates to the ethernet connection, and it’s something that’s not there when I connect via the wifi extender.

I’m stumped. Any ideas?

ps - with regard to the issue of SMB on the mac mini - the mac mini, my wife’s MBP and my MBP are all registered on the same appleID under iCloud, so they connect automatically without using an account login.
pps - I’ve confirmed the only device that uses a static IP is the NAS.

Do Fritzboxes let you export and re-import your config? If it’s not a setting you can find or some network configuration you don’t know about, it’s probably time for a factory reset.

Thanks bennyling. Good idea. I’d been assuming it was some configuration that I just hadn’t been able to find, so reset and restore would just put that bad config back on again, and I hadn’t wanted to put in the time to set it all up again from scratch.
However, I’ve just done the reset and restore, and so far so good. Although that happened last time too - I’ll be watching it closely over the next few hours. Cross fingers!

Well, it was working this morning, but then about 11.00 it suddenly broke down again - my MBP is again completely unable to ping any device that’s attached by ethernet to the router, while other computers on the network can do it no problem. I wondered if it might work after a safe boot, just in case there’s something on my computer that’s causing a problem, but the problem was still there.
It’s weird how it works fine for hours, but then suddenly turns, seemingly without any reason.
As I see it now, if I want to fix this I’ll need to wipe the router and set it up again entirely from scratch (which I’m not keen to do just from a time perspective), or just put up with it.
However, if anyone else has any bright ideas, I’d welcome them!

Wait, you restored your settings back onto it?

My suggestion about exporting and doing a factory reset was to allow you to test the router in its stock standard configuration, to rule whether or not out a customisation that you’ve performed is resulting in the strange networking issue that you’re seeing. If it was, then you could either a) set it up from scratch, or b) restore your configuration back onto it, with either method allowing you to know, with some degree of confidence, that it probably a setting that you’ve changed somewhere along the way that’s causing the issue.

If it still happened while the router was in a stock-standard configuration, you know the router is (probably) not the problem, and it’s time to start looking elsewhere.

Troubleshooting 101: simplify, then eliminate possibilities.

Ah, now I feel foolish! :slight_smile:

In fact I did test it in the stock-standard configuration, and it worked fine. But I can’t be certain the problem was gone, because it only falls over after a period of hours anyway. I’ll see if I can find a good time when I can set it up minimally and leave it for a day or two.

No, it was my fault for not making the intention behind my suggestion more clear.

That being said, hard to imagine there’s some user-configurable setting that causes your network to stop working/work differently after some period of time. I’d suspect some kind of timeout as the culprit, which you’d be able to discover by seeing what kind of network connectivity you do have immediately after a router reboot, and also after a failure, then doing a comparison and seeing what the difference is. Not just ping, but also trace route, DNS lookup, etc.

I’ve restarted the router (again), which has got everything working again, but I have every expectation that it will stop working again soon. I’ve copied a ping and a traceroute to the mac mini, and can do the same again when it’s down. How do I get a DNS lookup? Is that the same as ‘Lookup’ in Network Utility? Would the readout of ‘Netstat’ help?

Paul,
Can you confirm again, (I know you said in the first post) that when the dropout occurs you still have internet access with the MBP, just lose the ability to access the mini and the NAS ?
If so, then your MBP is still on the network with an assigned IP address, so it can’t be a general networking problem - like not getting a DHCP lease renewed, because you are only barred from the other devices.

Are you certain that your wife’s MBP IS connecting to the mini & NAS by the main network, and is not on the extended network also. - Don’t rely on her MBP’s location in the house, check the wifi network name she is connected to. - 2.4GHz has a lot better range than 5GHz.
Just trying to be absolutely certain about the situation.

Hi Jim, thanks for checking. :slight_smile:
Yes, that’s correct. I can connect to every other computer in the house, just not the one connected to the router by ethernet (and I can connect to it if I connect it to the router by wifi), and the (ethernet-connected) NAS. And yes, I’m able to access the internet with no problem. I’ve checked my IP address, renewed it, etc.
Yes, I’m certain my wife can access by the main network - she uses it for Time Machine on the NAS, and screen-sharing on the mac mini (we use it to play music on iTunes, so we control it by screen-sharing frequently). I had the extended network turned off for a couple of days just to make sure it couldn’t be affecting it, so I don’t think it’s part of the problem.

Paul,
There is a disconnect between the wifi and ethernet in the FritzBox for your MBP I think.
You can connect to the Mini & NAS when your MBP uses the extended network, which makes your MBP appear to be wired like they are, as far as Frizbox router is concerned. - so, all ethernet works. - If you have a dock or ethernet adaptor you could test by hard wiring your MBP to the Fritzbox to verify.
You can connect when the Mini uses wifi back to the Fritzbox, so all wifi works too.
So the dropout or timeout is happening in the Fritzbox, but only for your MBP. - Not a solution, but hopefully is of some help to a serious network technician to solve.

Okay, interesting. After dinner, I found the connection to the mac mini has fallen over, but the connection to the NAS hasn’t (yet). Bennyling, I suspect you’re right that it’s some sort of timeout - I had been transferring files on to the NAS just prior to dinner, and doing a time machine backup, so that was actively using the connection. But I hadn’t been using the connection to the mac mini for longer, and so that dropped out. I’ll be interested to see if the NAS connection is still there in the morning.

I did some scans of the mac mini connection before and after.
Ping before was fine, after is nil. Wife’s computer pings fine.
Traceroute before:
traceroute to 192.168.178.111 (192.168.178.111), 64 hops max, 72 byte packets
1 192.168.178.111 (192.168.178.111) 12.550 ms 5.452 ms 4.420 ms
Traceroute after (from wife’s computer):
traceroute to 192.168.178.111 (192.168.178.111), 64 hops max, 72 byte packets
1 192.168.178.111 (192.168.178.111) 4.273 ms 11.151 ms 3.594 ms
Traceroute after (from my computer);
traceroute to 192.168.178.111 (192.168.178.111), 64 hops max, 72 byte packets
1 * * *
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * 192.168.178.111 (192.168.178.111) 5.577 ms 4.996 ms
[So I think something got through in the end(?), but I ran it again and it got up to 25 with nothing so I aborted. Still can’t ping.]

So, I think I need to bite the bullet and set it all up from scratch.

Paul,
I use powerline (EoP) adapters too, and they provide a reliable connection for me. In fact my wifi Airport used in bridge mode as an access point is connected to the Telstra NBN router in another room by EoP and it never drops out the connection, - and obviously all wireless traffic from devices to the internet goes through the EoP route. - But could you try moving the mini and connecting it by an ethernet cable to the FritzBox for a period to see if it stays connected, and your MBP is able to connect to it. - This would narrow the issue down to being the powerline cabling itself or the range extender. :crossed_fingers: