Not receiving sms iphone 7


#1

so this may be a network issue or something random. I have people sending me sms recently which I don’t seem to receive. sms I send them get through, but theirs don’t come to me. I recently upgraded from my crappy old 4s to an iPhone 7. any ideas, i’m clueless?


#2

Sounds like it could be an issue with Carrier Settings:

You can try following those steps to see if there is an update (although it usually tells you anyway).

I’m sure there is a way to force it with one of those *# or ## codes you can enter but I can’t for the life of me find one using google right now.


#3

Do their messages eventually arrive? I had an issue similar to this. Messages that I know people had sent didn’t arrive via the phone network but did arrive when I was connected to wi-fi later in the day. The setting is “Settings-Messages-Send as SMS” Your friend should check that this is turned on. I think it is off by default.


#4

so carrier or provider settings seem okay.
nah, it just seems to be from some people, I get messages from most. not sure if there is any correlation with the provider they are on (don’t know who they are on).


#5

My son had a similar problem once. It was solved when he checked his imessage send and receive addresses. His phone number was not ticked. See Settings/Messages/Send and Receive


#6

i can’t see any ‘send and receive’ setting

BTW, I don’t use imessage, have it switched off if that makes adifference


#7

So it seems some have been going to my sons phone. All started around time my phones be died and I got a new phone.


#8

that definitely sounds like an imessage/icloud type problem. It’s not possible for an SMS to go to a different phone if your SIM isn’t in it, but it’s entirely possible for an imessage to go to a different phone if they are using the same apple ID. you should use a separate apple ID on both devices, and if necessary set up family sharing for apps etc.


#9

Sounds like your number is registered to receive iMessage, even though you have it switched off on your phone.
You can ensure it’s disabled for your number here https://selfsolve.apple.com/deregister-imessage/


#10

Yeah, same Apple ID used on all phones


#11

Yes. It’s annoying that turning off imessage in your phone settings doesn’t accomplish the same thing. When I recently switched to Android and turned imessage OFF on my iphone, I had a bit of confusion with people sending me messages from iphones, and I had to de-register using the above link to fix the problem.