Reset Mac App Store/Software Update?

#1

G’day,

When I purchased my Early 2009 iMac, it came with 10.8 installed. I made use of the free upgrade to 10.9 via Apple’s website, and then increased it to 10.9.2, however since then I could not convince the Mac App Store to upgrade to 10.9.5. I would continually face a permission error - 513 - which would not give up the ghost no matter what I tried. (Repaired permissions, new user, root user, some shit in terminal that reset settings…)

Finally tonight I tried the only other option that someone suggested either on MacTalk or Apple Discussions - putting the iMac into Target Disk Mode and using another Mac to perform an upgrade using a Combo installer. So, I did that… watched with baited breath… restarted… and after about 5 minutes of grey screen/Apple logo/spinning circle, it finally came up with the login screen.

Check the About This Mac, and yay - it says I’m now running 10.9.5.

Except… When I log into Mac App Store to check for other updates, in particular iTunes, it first was suggesting the 10.9.3 update (!), then tells me that I have already installed iTunes 12 - however I am only running version 11.

I tried deleting the software update preference file, and a storeagent plist as well (as per some website’s suggestion), but it didn’t make any difference.

Is there some way to convince Mac App Store to recheck my system, and provide correct information and updates???

Even more annoying - I can’t simply go into Mac App Store and download iTunes manually… Doesn’t appear when you do a search…

cheers

cosmic

0 Likes

#2

Cosmic,
Get iTunes from here.
The old fashioned way.
But I get your point that it should be just another free application on the Mac App Store.

0 Likes

#3

smacks head

Did not even think of that, as figured Apple was pushing everyone to the store apps…

Gets around the annoying permission error for now.

Thanks (:

0 Likes

#4

Same story for the combo update, why not just download and install it locally rather than use target disk mode (which is hurting my head just wondering how that would even work).

0 Likes

#5

Tried; it wouldn’t instal. Would say it needed to restart, restart, then just go to the login screen. No installation happening… Not from the machine itself.

Had to put it in target disk mode, hook up my MBP via FireWire, access the combo file (on the iMac)and instal that way…

0 Likes

#6

I just tried the same approach to installing the security upgrade that Software Update has been trying to install.

It errored out, and tried to tell me - "you may want to ", and the text then runs off the window and disappears…

I presume this is part of the real problem… the 513 permission error…

0 Likes

#7

So, I just updated to Sierra, and again was hit by a permission denied issue when trying to use the App Store updates - error 13 this time.

Tried fixing permissions in Terminal but no good.

I did some looking around Apple Communities, and found this:

sudo chown -Rf 200:200 /var/folders/zz

Problem solved.

0 Likes