Safari not defaulting to google.com.au?


#1

My Safari used to default to google.com.au when I typed into the address bar at the top, but it seems to have ground to a halt and goes to google.com now. Any ideas?


#2

Firefox here, too.


#3

Have had similar issues!


#4

Ditto, but the search results are for Australia… does it matter that much?


#5

My issue - it doesn’t offer the “search only in Australia” option unless you go to the AU site.


#6

So put in site:.au as part of your search term?


#7

What i meant was, that without asking for it to only search for Australia, it gave me .au results anyway.


#8

It does, but if you are looking for sites, you can’t confine the results to australia only with the dropdown and sometimes international sites appear


#9

Right. Same with duckduckgo which isnt as good as it used to be. Interestingly, safari on the iPad does go to .com.au.


#10

Just checked. Firefox does have the option to use Google Australia instead of Google(.com) - BUT - it actually does the forced Australian sites only by default.

Once upon a time, I presume it told by your IP address what country you were from, and used the applicable google.com.x. Then you could use the forced .au results if you wanted - or not.

It’s a minor issue, certainly. But annoying nonetheless.


#11

Is your computer’s locale set to Australia? There’s a bug in the keyboard settings where they will reset to the US.


#12

The locality is set to Aus, but the keyboard was set to the US. Have changed and will see if it has any impact