TV app for iOS


#1

How does one get the TV app to appear on their iOS devices? It was made available on my Apple TV 4th gen yesterday, but alas, it was (mostly) non-functional. However, I don’t have it all on my iPad Pro and 6s Plus - both of which are on iOS 11.


iOS 11 is out
#2

Had a quick look n my appleTV this morning. Looks quite functional (for watching FTA programs). I assume it has some level of intelligence to adapt to programs you watch?

Did not know this available in iOS 11 as well?


#3

Yeah, I haven’t checked the ATV this morning, but I’m sure it will work today (being the 20th).

And yes, it is also meant to be available on all iOS devices as of today - https://www.apple.com/au/tv-app/


#4

I’ve been living a little under a rock when it comes to TVOS. When I saw it on the ATV4 last night I tried it but it didn’t seem to do much of anything so I figured it was more of a US-centric app so pushed it down to the bottom of the list when I could ignore it.

Maybe I’ll look into that more over the weekend.

iOS 11 is loading now so I’ll see there soon.


#5

There was some sort of change to it last night (non functional) in preparation for iOS 11.

I have now find it on my updated iOS devices. From a quick look, quite similar.


#6

That App is a UX mess. I just skimmed the Apple page, and still have no idea how (if at all) it works… :thinking:

Seems to be designed to combine multiple streaming services together? I wonder a) how well that works and b) what services don’t work with it. I wonder if Plex does…?


#7

So the TV app replaces the old videos app and it’s a bit confusing. All the TV shows (and movies) on my phone are things I have loaded up manually (ie not iTunes Purchases).

So the ‘Watch Now’ Tab seems to make sense, but it crosses multiple platforms so it will be interesting to see how useful it is. I’ve already seen content on iTunes/Stan that I would have to pay for show up in the lists, which is fine if you have subscriptions (or don’t mind paying for everything) but is just frustrating if most of the results are not relevant. It would be great if there was a way to hide content that I don’t already own (or can’t access for free).

The ‘Library’ tab is showing “recently purchased” TV and Movies, although these are things I have loaded rather than actual purchases through iTunes (although maybe it really means ‘recently added’). We will see if this changes as I sync in new content over time (rather than what was already on the phone before the upgrade).
Interestingly it now lets me watch videos in portrait mode, with WILD letterboxing of course, you can even double tap to expand the video to fill the portrait screen which is even totally useless with 16:9 video since you lose most of it. Why you would want these options is another question, but hey, new features are new features :stuck_out_tongue:

The store tab does what it says on the box and includes pointers to SBS, ABC, 7, 9 and 10 apps. Clicking on them takes you to the app store to download those apps, they appear to show up just like they used to as stand-alone entities. Using the ‘Watch Now’ tab and clicking play on something available on SBS seems to just jump into the SBS app, which makes the TV app seem less useful… especially if you don’t want to pay through iTunes or Stan. I haven’t had time to see if any of the other broadcasters will integrate into TV, I assume if they don’t now, they will be able to if they choose. I do note that there is a message that says Apple is collecting information on what you watch including through SBS. Through the others too? Maybe? Probably?


#8

Grr, frustrating that I’m still seeing the Videos app, and not the TV app. Have tried rebooting a few times, no change. The TV app isn’t even showing in the App Store. Any ideas?


#9

Digging a little deeper into the app and I’m seeing things like ‘Australian Survivor’ and ‘The Block’ coming up for 10 and 9, even though I don’t have all the apps installed. Clicking play on one of the apps I do have causes it to switch to that app and play the thing. If I don’t have the app it prompts me to install it. Not bad really.

I’ve actually found a few interesting looking things while flipping around.


#10

I wonder why mine is not doing anything. I’ve shoved it down the bottom of my app page, because for now it is completely useless.


#11

What device are you using the TV app on? What OS version have you got?


#12

This is all on iOS for me. I tried TVos last night and it didn’t do anything. Everything today was on my phone running iOS 11


#13

Cool. Chatted with AppleCare support earlier tonight, they couldn’t work out why I don’t have it. Going for the Restore option, in the process of doing it as we speak. Might’ve been because I jumped the gun and downloaded the iOS 11 GM? :man_shrugging:


#14

I had the same problem. The TV app did not appear.

The solution for me was pretty simple though. Redownload the Videos app from the App Store, then reset all settings.

Your device will reboot and will “convert” the Videos app to the TV app.


#15

The TV app was showing my purchased TV stuff last night but nothing from iview, sbs etc, and now this morning, its gone again. shrug


#16

For me, the TV App was showing on my Apple TVs on Tuesday night/Wednesday morning then just disappeared when I pressed the home button! :open_mouth:


#17

Used the TV app last night. The way it consolidates catch-up with what’s available on the iTunes store is really neat. For example, the 1960s Batman series shows as available on SBS On Demand as well as iTunes, gives you the option for either service.

I also discovered that a series I’ve been waiting for has already aired seven episodes, all available through Tenplay. I had no idea until the TV app brought it up. Started playing without a hitch. Super useful. :+1:


#18

Mine is back now, and working as its supposed to. A nice touch is that whatever you do with it on your iPad or phone is reflected in the app on AppleTV. That will be about icloud. I only have 5GB there so I probably wont be using it much, in any case. UNless someone can explain that it won’t fill up my storage space.


#19

So the Apple TV, TV App appeared on my device before the new tvOS upgrade had arrived but has since disappeared. Is it supposed to return? or do I need to update to the new tvOS?


#20

updating is what fixed my anomalies.