Unzipping a zip file


#1

Zip files won’t unzip now on my MacBook Pro 10.11.06. Double clicking just creates a duplicate Zip file. If they are unzipping somewhere in the background, where can they be viewed?

Searching on-line I found these instructions:

Control Click on the Zip file> Open with> Archive utility, which I’ve tried clicking. That briefly displays a progress bar window claiming the file is being unzipped. That last for less than a second then another dupicate appears, which won’t open either.

If it is unzipped where has it gone? It’s not on the desktop or in the folder where the original is kept. I’d appreciate some clues please.

My aplologies if there is a very basic solution, but I can’t find it. ( Please don’t direct me to terminal, I don’t go there).


#2

It might be that the file that you’re trying to unzip is in an unsupported compression format or it might be that it’s incomplete or corrupted or possibly encrypted (and needing a password).

Have you tried other Zip files to see if the same thing happens?

One other thing you could try is using a 3rd party ZIP utility like Dr. Unarchiver (which is free) and is available from the Mac App Store.

Dr Unarchiver link


#3

Try http://www.kekaosx.com/en/


#4

Once upon a time you had to rely on 3rd party apps to unzip files on a Mac unless they were a very very select group of compression formats…

Then - did Apple buy out Stuffit? At any rate, Apple seemed to catch up.

Now…?


#5

Thank you Geoff and gehenna.

The Dr Unarchiver link is dead. A search of the Apple store didn’t find it either.

I looked at the link for keka and will keep that in mind, thank you.

I did try unsuccessfully to open other files which had opened previously so thought I’d make a new one to experiment on…Selected four files on the desktop> File> Compress >. That created a file named ‘Archive.zip’ on the desktop. > File > Get info.

The info window gave the opportunity to Open with Archive Utility (default) and the option to use this app to open all docs. like this one. Pop up window asked if I wanted to change all similar documents, change would apply to all docs. with extension .zip. Took a deep breath and did it.

Now a previously locked .zip file will open when clicked, as a file folder, with the exception of one with .zip.cpgz, which probably requires a password, as Geoff suggested.

cosmic, the capability is there, lurking. I guess the setting must have changed during a recent upgrade. I’d forgotten about ‘Get info’ suggested when board members helped out after Firefox inserted itself as the default in place of Preview after an upgrade…doesn’t take much to confuse me!


#6

.zip.cpgz is not a zip file. The original file is probably compressed using another method – “gz” is gzip2 compression – so the archive utility gets confused when trying to unzip it. It’s a very old bug. Try re-naming the original file that wont uncompress to “.gz” instead of “.zip” and see if that fixes it.

The other thing you can do is see if the system can recognise the file. Open the Terminal, type (without pressing return) “file” and a space, then drag the file to the terminal window and press return. You should get some info telling you what kind of file it is, hopefully not just what the file extension suggests.


#7

I had never heard of that trick to identify a file’s “true” file type!

Ok, kinda painful cos it involves Terminal, but still - useful to know! :slight_smile:


#8

Thanks Currawong. It’s not an important file. I just tried to copy an on-line registration form and save it but took the precaution of taking screen-shots of it anyway.

I recognize that Terminal is outside my turf, who knows what I could damage irreparably?

Now, if I can just make the printer work…


#9

I’ll throw in another thought here, for anyone who might find this thread while searching for the same problem: Web pages these days are sent compressed over the internet using gzip compression. There was a wacky bug that if a web page or object was downloaded, it would download the gzipped version instead of the uncompressed version. I can’t remember offhand if it was an error in the settings of the web server (eg: forgetting to set zip files to be sent uncompressed) or a browser bug.