Airpods Issue

I have an irritating repeated ‘fail’ with my AirPods (Gen 3).

Use them for work for video sessions with clients; via clinical ‘telehealth’ software (not Zoom).

At work, on Windows, I’m able to connect and the AirPods work flawlessly. Can use them on my phone, then back to the PC, reconnect, works.

But at home, ironically on my 27" iMac, I lose outgoing sound on the AirPods. Clients cant hear me. I can hear (and see) them, they can see but not hear me. But not always.

The issue is inconsistent and seems to occur after I’ve disconnected the AirPods to say, have lunch, or use them on my iPhone. Thereafter, the microphone in the AirPods appears to no longer work…except it is working, as I can use it to dictate into a doc, and in ‘Settings’ under ‘Sound’ I can see the graphic picking up my voice. But people on video conference cant hear me.

Microphone and video are switched on in the website in Safari.

iMac is running the latest OS; no idea if the firmware is up to date on AirPods (how do I tell?).

The great disappointment is the issue occurs using all Apple devices, and not when using Windows. Go Figure. Have lost confidence in using them with my iMac.

ALREADY TRIED…
I’ve disconnected and reconnected the AirPods, turned Bluetooth off and on, and disconnected from my iPhone - no change.

Any ideas??

UPDATE: tried to use them via my iMac on Zoom, and same issue appeared. Disconnected the AirPods and just use the iMac’s own microphone and speakers, worked perfectly. So the issue is with the AirPods, but seemingly only on the iMac - go figure!

Have you tried resetting your AirPods to factory settings?

Thanks, I havent but I will, as they are basically unusable on my iMac now. They work on every other device, so bit mysterious.