Mac won’t recognise External USB Drive

Hello brainstrust.

Please help!

My trusty old school external USB drive doesn’t want to appear in Finder or Disk Utility.

I’ve googled, I’ve troubleshot. And I’m stumped.

It’s an IDE drive in an enclosure, power supply functional. Drive spins nicely. Drive responds when USB cable connects to Mac.

Not precious about the drive or enclosure, but would like to access contents if possible.

Any help appreciated!

First thing I’d try is a different USB cable. And wobble it around a bit. A different port on the Mac too. After that, try restarting the Mac with the drive plugged in. What Mac are you using & what OS?

1 Like

Whenever I’ve had this kind of issue (with several WD drives), I’ve found that it was the enclosure with the problem. As I had a G5 / Mac Pro, I could just remove the drive from the enclosure and pop it into one of the internal hard drive bays and continue to use the disk…

Of course who uses a Mac Pro these days - you could instead get an external drive docking station, and connect it that way to your Mac.

Of course - try the usual things first like @richard suggests… I don’t know if it’s really going to help but found a site that also suggests resetting your Mac’s PRAM and SMC, and probably before that - try Disk First Aid to see if the Mac can even see that there is a hard drive trying to connect… and run repair if it can.

1 Like

It might be hard to find an IDE compatible docking station. I only see SATA Drive compatibles available. One of these old babies is probably the cheapest way out. I have a very old one. OWC still has them for sale at $28 USD + shipping.
Alternatively, know anyone with a 15 year old PC you could try it in ?


Thanks, have tried a different cable and attempted to connect on multiple ports on iMac and MBP. Main machine is the 2021 MBP with Monterey.

Normally, I’d assume it was just the drive failing except I can hear it spinning and it sounds fine.

Yeah, I opened the enclosure last night and everything seemed perfectly fine.

I have a spare enclosure somewhere that I’ll try and dig out.

The disk doesn’t come up in Disk Utility. Is there another app you’d recommend for First Aid?

You could try running First Aid via Terminal - as shown above… although to be honest - I think since System X was introduced I’ve never actually had an instance where First Aid solved a problem. (Which I think is more an indication that Apple have improved their disk tech / interface than First Aid not being good…)

If your other enclosure doesn’t solve the problem, you may get lucky with some 3rd party recovery tools to recover data… No idea what’s actually good these days.

1 Like

I didn’t even know such a thing exists! Thanks! If I can’t get it to work that might be the best bet.

Ahhh, makes me wish I’d kept just one g4 tower or eMac…

Thanks I’ll give this a go today too.

I’ve never been adept with terminal. But I know how to copy and paste!

eMac… ick - wouldn’t want to be swapping the HDD over too often in them! The optical drive was bad enough.

Yeah - I am not a fan of Terminal, but like you - I can copy and paste. The biggest issue I find is getting the drive correct. But if you do a bit of playing around first in some basic Terminal commands, you’ll get the feel for it.

I’ve got one of these. Unfortunately, I’ve never found it to be very reliable.

Here’s a cheaper adaptor available from our local Amazon Store.