"This app is no longer shared with you" Family frustration


Talking of things just not working…

I purchased an app for my kids, using my iTunes account, as admin of my family group.

One kid - the game auto downloaded direct to his iPad. (No idea why that happens…)

The other - when we try to download the app, it then says “This app is no longer shared with you. To use it, you must buy it from the App Store”.

Going in to buy it does not work, as it says - it’s already been purchased by a family member.

I’ve tried offloading, and deleting it… I’ve restarted the iPad, and my iPhone. I’ve turned off all Screen Time controls (in case it was deemed inappropriate for kids).

I am at a loss… and have an 8yo that is realllllllly not coping with this situation.

There’s numerous websites with suggestions on how to remedy, mostly using the above steps, and nothing works.

Apple, I hate you.


Is there an option anywhere to look at apps downloaded/purchased by other family members? I’m pretty sure I remember seeing something of the sort that basically listed all the apps my wife had ever purchased… So many games!

When things “just work”, I love Apple.
When things don’t “just work”, (with typically almost no tools, data, or useful error messages for diagnosis and fault finding,) not so much.

What annoys me most is when I find that the problem has been occurring for years, yet Apple provides no recognition nor consolidation of symptoms and possible solutions.

Yep - on the kids’ iPads, in the App store, when you go into Purchased items, it breaks them down by family member.

So the game in question is sitting under my purchases. You can click on it there to download it from the Cloud icon. It downloads… I expect possibly at that point the cloud icon, which became a circle during download, should say “Open” (?) - but instead it remains as a circle with a line around it - ie completed download.

In order to open the game, you need to exit the App store, and find the game’s icon on the iPad desktop. So - find it, open it, and then - the above error of “This app is no longer shared”…

Even if I go back into the App store and offer to pay for it again, it doesn’t let me get the game cos it says - this was downloaded by a family member.

And suddenly… the game is working.

deep sigh

One very happy 8 year old…

I downloaded another game for him (not a pay one) this afternoon, and checked again - the pay game was still not working.

But then, he came up to me and said - what does this say? And it was a window asking about accepting terms/conditions. Clicked OK, and - the game was up and running.

Sheesh, Apple. You suck. This was obviously not user error… And nothing I could have done would have fixed it. Hours of time wasted.