When it doesn't "just work"


Is it just me?

I know that back in the day Apple’s motto was “It just works”… And - in reality, whilst a lot of the time it did, there would have been plenty of times that it just didn’t, too.

But - has it seriously gotten a lot worse?

I know I’ve posted on here a few times lately about things that should have been simple and that Apple have solutions to make it simple - and yet - it just doesn’t go that way.

This past few days I’ve been trying to migrate iPad A to iPad B, and then iPad C to iPad A. IE - There’s a new iPad, and we’re shuffling down the line.

Apple has an automated, wireless process to help migrate your data - settings, and apps - from 1 device to another without needing a computer… BUT, it easily seems to get stuck in a loop, going round and round without resolution, which is what’s been happening to me.

When I tried connecting the iPad/s to my Mac, it errored saying there was an incompatibility. No information about WHAT was wrong however… I assumed Mojave was too old, so didn’t continue. Later, I found out that yes - it will work on my computer… I have no idea what software was updated, but eventually was able to proceed, only to then fail to copy over a backup of 1 of the iPads to another one, because the iOS was too old on the iPad. This however made no sense… (as the iOS on the backed up device was older than where I was trying to put the data…)

Overall - just a very frustrating experience, with a lack of feedback from Apple to tell me WHY it can’t do the processes it’s trying to do.

I presume this is because Apple has long ago made the assumption that their consumers are idiots.



1 Like

I had absolutely no trouble whatsoever transferring my iPhone XR to my new iPhone 15 Pro about a month ago but I bought my wife a new iPad for Christmas & it took quite a few attempts to get that transfer to complete. And I’m still not certain that it completed properly.

I did a shuffle of iPads recently after one got handed down the line (with me at the bottom :stuck_out_tongue: ).

The only issue I had was not realising that one of them was only a 32GB base model (at least the base is now 64GB). Sadly Apple doesn’t actually tell you that when you’re doing the restore… only when it fails to install everything from the backup. It did actually transfer though… so I suppose it does “just work” :stuck_out_tongue:

Sadly, for power users it’s a PITA when “just works” means “zero control”. I’d love an advanced button that let me into some of the sub setting/controls to tweak things. …and don’t start me on the recommended support step that is “reformat and don’t restore from a backup”

I think Apple assume that their users only run the latest software and hardware and only ever move up the stack. If you don’t, good luck.

I completed 3 iPhone transfers, 1 Mac transfer and 2 watch setups post Christmas. These all happened without a hitch and at moments I found myself reflecting on how far we’d come since cloning drives via FireWire, and backing up and restoring phones to iTunes.

But yeah, then there was that one phone that refused to download Apple apps post transfer. No reason given. It just ‘could not download them at that time’.

Hours spent troubleshooting, multiple processes recompleted because it didn’t ’just work’.

I think things still work very smoothly most of the time, but boy when a process breaks down and there’s no explanation given a lot of that good will goes out the window very quickly!

I’ve always backed up to a Mac and restored to the new device… It’s just habit from the old days and I’m more comfortable with it…

1 Like

I did for years too, typically with no fuss or bother. However in recent years Apple seems to encourage direct device to device transfer. This may be faster, but I feel it has been more glitchy.

I always make sure I have a backup on my Mac just in case.

I definitely agree. My 13 Mini has been my buggiest iPhone ever, things just DON’T work.

The last few years (supporting Macs in education and in the home) I’ve seen Apple’s software become more unpredictable and more buggy.

Apple need to dump the ‘new version of MacOS and iOS every single year’ philosophy. MacOS never actually matures into a stable operating system because just as it’s starting to get there, a new version comes out, all development moves to the new one and the old one just gets security updates.

It’s beyond frustrating.

1 Like

An example from today (unfortunately my experiences are also growing).

This week I have been reading and annotating (highlighting) a large and detailed academic papers (PDF) in the Files app (iPad Pro).

I’ve started noticing two different colours being applied to a single highlight — when i come back to look at them (happened several times in the last couple days to different papers). Selecting ‘remove’ goes back to a single colour.

Today I removed two of these second colours, and then noticed that the highlighting for the second half of the document have disappeared… Hours of work lost :face_with_head_bandage:

My new Mac Studio will arrive tomorrow so I will be setting it up/transferring all my info over the weekend. At this stage I’m thinking of using Migration Assistant to transfer from a Time Machine Backup upon setting up the new computer. So we’ll see if that “just works”.

That’ll take forever. IMO you’re best to migrate manually or from your old computer.

The Mac Studio still hasn’t arrived for some reason. Hopefully will turn up by the end of the day. Shouldn’t take too long. All my movies, photos, music are on an external drive & the Time Machine backup is on a fast Thunderbolt NVME drive. Only about 225GB to copy over.

So, I set up my Mac Studio this afternoon. All went well. I decided, rather than use a Time Machine backup to transfer everything over, I would use a Carbon Copy Cloner clone. But I made a new Time Machine backup as well just in case. I dare say the Time Machine Backup would have worked just as well. It took about 15 minutes to migrate everything.