Who is beta testing High Sierra?


#1

I just decided to live on the edge and install one of the High Sierra betas on my MacBook Pro. Runs very nicely so far, but the App Store has informed me that it’s not the latest Beta. The newest one is Beta 8, is anyone running Beta 8, and how is it running for you? Once I feel comfortable with it on the MacBook Pro, I may go ahead and patch it and toss it on the Mac Pro.

Of course, yes, I have boot drive back ups, and back ups of back ups, and back ups of back ups of back ups, so I’m really not afraid of running a Beta OS on my daily driver.


#2

I’ve been using the HS Public Betas since Public Beta 2 and it’s been fine. I am waiting on a driver update from HighPoint for a Thunderbolt 2 RAID enclosure to come so I can use the drive again under HS.


#3

I’ve been using since PB3. No issues at all. Have run it on a 2015 MBP until yesterday when I got a Touch Bar MBP. Works even better on this one.


#4

Apple. Apple is beta testing High Sierra. :smiley:

I am certainly not! :joy:


#5

I think I want to clean install High Sierra this time around, but for whatever reason, even though I’ve followed all the steps to enrol my Mac, when I try and download the macOS High Sierra beta from the Mac App Store, it downloads a tiny 20MB installer that then says it can’t contact the recovery server when I try and install it.

Anyone else seen this issue? Is it because I’m still on Yosemite and can’t jump from 10.10 to 10.13? Latest updates otherwise, and I’ve rebooted recently…


#6

I will likely to a fresh install as well (Touch Bar MBP), after using migration assistant last time around…


#7

It does download a small installer first, when you enrol via the website. But that small installer then calls up the App Store and from there it downloads the High Sierra installer. At least that was the workflow for me. So you might be right about the version hops, or you truly do have some issue stopping you from getting to the verification server.


#8

Yeah, I’m not sure what’s going on either. Tried again this morning to download the GM from the Mac App Store, same issue.

Changed my DNS, flushed my cache, same issue.

Starting to think it might be because I don’t have a Recovery partition? Might put that back sometime over the weekend to see if it makes a difference, will report back, otherwise I’m thinking I’ll just download it from another Mac.


#9

Well, I see an issue for putting High Sierra on my Mac Pro at this point anyhow: the required update to my NVIDIA drivers doesn’t have a High Sierra version yet. I’ve needed to update my NVIDIA drivers immediately after every single update of Sierra, so I am pretty positive that I’ll need new drivers. I bet those won’t drop until the official final release on September 25th. For that reason, I’ll hold off on putting it on the Mac Pro.

But it’s running perfectly on the MacBook Pro. It’s not even noticeable as far as being a different user experience. It’s a bit snapper though, and I’ve seen something of a drop in RAM usage.


#10

The GM Candidate is out, but you need to login back to beta.apple.com and download the full installer from the Mac App Store.

Build number is 17A362a


#11

Meh. Final release is in 10 days. I can wait. Especially since I still don’t see an NVIDIA web driver updates.


#12

GM came through for me overnight. Running now, super slick. Runs awesome on my new MBP.


#13

Installed the GM on my 2013 MBP. So far I can not tell the difference, LOL.


#14

Snow Leopard all over again :slight_smile:


#15

We can only hope. I think Snow Leopard has to be up there with 10.4 as one of the greatest Apple OS releases of all time (following one of the worst in Leopard).


#16

I ran Snow Leopard on all my machines for years and I still have two running it - our Mac Mini server because I can’t be bothered updating it, and another Mini for running a PPC version of MYOB.


#17

Snow Leopard was one of the best operating systems Apple produced. It also ran Premiere 6.x still. And very well at that. Every now and then, I consider reinstalling it!


#18

And now it looks like a bunch of people are having hissy fits over the news that APFS won’t be supported on Fusion drives. The fact that it was and then it wasn’t suggests that they may have run into some unexpected problems with it. Or, maybe it’s indicative of the complete incompetence of the entire management team. Apple is no doubt doomed and we’re all going to die. /irony


#19

I’m running APFS on my SSD. Haven’t had a bit of trouble, and I’m about to clone this over to RAID 0 SSD. I am confused. Is this just fusion drives, or any SSD drives? o.O


#20

No, just Fusion is the report. I’m guessing spinning rust is the problem - it’s probably not supported on any traditional disk drives.

And, whilst I admire your courage, file systems are a pretty big deal and not something I would ever run in beta on a machine that mattered. There are probably people on this forum who were yet to be born when Apple last changed their file system - MacOS 8.1, in January 1998! And, as much as I’m looking forward to the new shiny, and I really am looking forward to APFS, I will be waiting until at least 10.13.1 before I migrate the machines I rely on.